2

I'd installed an Ubuntu distro alongside Windows 8 that I didn't like. I was going to replace it with standard Ubuntu, but it was having trouble, so I deleted the Ubuntu partition from Windows 8. I was going to fix the MBR before rebooting, but it turned off. So anyway now I can't get past the grub rescue when I start the computer:

error: unknown filesystem 
grub rescue>

so I can't boot anything - HDs, DVDs, USBs.

ls is one of the few commands that works and spits out: (hd0) (hd0,msdos6) (hd,msdos5) (hds0,msdos2) (hd0,msdos1) (hd1) (hd1,msdos1)

Hd1 is a USB I have plugged in (Ubuntu live). I've tried:

set root=(hd0,msdos6)
set prefix=(hd0,msdos6)/boot/grub
insmod normal
normal

I never get to normal though. When I put in insmod normal, I get "error: unknown file system."

I'm assuming msdos6 is the boot partition (primary), msdos5 is Win8 (primary), msdos2 is was the logical extension with Ubuntu which I cleared, and msdos1 is the linux swap. I guess it could be the other way around though. Either way, insmod normal doesn't work because it doesn't recognize the file system.

When others have asked this question on yahoo answers, most people have suggested booting a CD/DVD/USB, but that doesn't work. I can't boot. Is there any way I can boot from here to fix my MBR?

  • Can you access your bios ? have you checked the boot settings in it ? – Aserre Jun 2 '14 at 9:00
  • You have first to restore Windows bootloader, then install Ubuntu, but it's not clear why can't you boot from CD. Please add the details. – Danatela Jun 2 '14 at 9:03
  • I don't have access to the bios. It goes from the "LENOVO" screen straight to the grub rescue. The "press f12" option for the boot is missing from the lenovo screen. – welund Jun 2 '14 at 9:39
  • How to access the BIOS - ThinkPad – bain Jun 2 '14 at 15:56
  • @bain: the F2 button doesn't work. That's part of the issue. However, one thing you can apparently do is reset your BIOS by unplugging the CMOS, then starting the computer again, which will give you an error, forcing you into BIOS set up. At that point I just set my CD drive to boot before the HD, which loaded up my Super Grub Disk. – welund Jun 2 '14 at 18:06
2

Reset your BIOS by unplugging the CMOS batt, then start the computer again, which will give you an error, forcing you into BIOS set up. At that point I just set my CD drive to boot before the HD, which loaded up my Super Grub Disk.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.