Updated Ubuntu from 12.04 to 14.04 LTS. All seemed to go smoothly. After re-boot, the desktop displays the wallpaper and my user name appears with a password prompt. Ubuntu 14.04 LTS appears in the lower left. The mouse is detected and works as described below. After entering my password, a message box appears with "System program problem detected. Do you want to report problem now? cancel report problem?

Selecting either choice results in the message box disappearing but no desktop icons appear and the wallpaper remains. There does not appear to be any way to start a terminal, initiate a shutdown/re-boot and make any selection. I have to do a hard power button reset to get off the wallpaper screen. I have already tried this recommended post:

Press Ctrl+Alt+F3-> ENTER YOUR username & password -> enter these commands-> sudo apt-get update -> sudo apt-get install –reinstall ubuntu-desktop -> sudo apt-get install unity -> sudo shutdown now -> Turn On your PC & check! – Jax-L May 2 at 16:11

and I have tried this similar posting:

sudo apt-get update 
sudo apt-get install ubuntu-desktop 
sudo apt-get install unity 

Thanks for any reply.

  • possible duplicate of Graphics card problems after update Jun 2 '14 at 1:50
  • you need to enable the unity plugin in ccsm
    – mchid
    Apr 4 '15 at 17:41
  • Can you open terminal with ctrl +alt +t Apr 4 '15 at 17:41
  • It's a little confused. If you put a print-screen in here will help. Jun 28 '15 at 16:41
  • you need to enable the unity plugin in ccsm. this is a common issue when upgrading from 12.04 to 14.04. once you enable the plugin (which did not exist in 12.04) you will have a launcher and a panel.
    – mchid
    Jun 28 '15 at 17:01

I had similar issues when I first loaded Ubuntu 14.04. It ended up being my video drivers were not installed properly. The drivers I had issues with were connected to Nvidia and it seems that Ubuntu 14.04 did not come loaded to install these drivers. I also had to set the display to the default to get my drivers to work properly. The commands I used are as follows:

set display=:0

ubuntu-drivers devices | grep recommended

This command will give you an output stating the driver file that is recommended for your system. Then use the install command to install it:

sudo apt-get install (recommended driver file)

sudo apt-get update

sudo apt-get upgrade

Reboot the pc, and see if this has repaired the problem.


Does your guest session work? If so, your problem is a conflict with the old desktop configuration files. A fresh start should fix things. Try backing up all the files starting with a dot (e.g. .Xauthority) and deleting them (directories too), from a virtual terminal (Ctrl-alt-F1). Then try the graphical login (Alt F7) (or reboot). New "dot" files will be created as needed with the new formats.

gsettings set org.gnome.settings-daemon.plugins.background active true 
gsettings set org.gnome.desktop.background show-desktop-icons true 

for those who still use 14.04 (strange way of formatting comments)


I'm assuming you are referring to the unity launcher, i had a similar problem after installing 14.04, try pressing F1 when booting your PC, that will prompt you a menu where you can select which version of ubuntu to boot, select the one does not mention (safe mode), i should be fine.

If is about icons missing from your desktop just launch nautilus in your unity launcher and place them in the desktop folder, then you should regain them.


Similar to Dhartman2076, and following an Ubuntu forum post, you can reset your Unity icons:

sudo apt-get install dconf-tools
DISPLAY=:0 dconf reset -f /org/compiz/
unity --reset-icons
setsid unity

Note that if you run these from graphical mode, it will do funny things to your screen. (All my windows lost their borders when I did it.) You could instead type them on a true terminal console by typing Ctl+Alt+F1 to go to the console, and typing the commands there. I put them in a file by using

cat > tmp-instructions

followed by pasting these instructions into the file, and the typing Ctl-D. Then from any command prompt in the same folder, I can read the instructions again with

cat tmp-instructions.

With the instructions above made accessible from the command prompt in this way, I found it easier to proceed.

Then you can reboot once you've run the commands.

sudo reboot

Final warning: This could also seriously mess up your desktop. I have no idea, I'm not familiar with these commands. But it worked for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.