0

Problem :

Wi-Fi networks not detected anymore

What triggered it ?

My computer froze and I ended up having to restart it using the power switch. In case it could be relevant : it froze while I was using Calc, trying to drag and drop items (bug already filed in LibreOffice).

What have I attempted to solve it ?

I was under Kubuntu 13.10 when it happened, so I took this opportunity to reinstall the OS with Kubuntu 14.04 (no config files were kept), but it didn't solve it.

Current diagnosis :

When running "sudo iwlist wlan0 scan", "wlan0 No scan results" comes up.

The /var/lib/NetworkManager/NetworkManager.state shows :

  • NetworkingEnabled=true
  • WirelessEnabled=true
  • WWANEnabled=true
  • WimaxEnabled=true
  • WiMAXEnabled=true

What could I try ?

0

It was a hardware problem more than a software one : I ended up resetting the BIOS to the default settings, but doing this wasn't enough : unplugging the charger cable and removing the battery before restarting my computer was needed too.

Maybe if I had just tried removing the battery and charger, without resetting the BIOS fist, it would have been enough (since I can't remember having made any significant change on the BIOS before), but I tried the other way round.

This problem was triggered when my virtual memory got overloaded, so I guess it makes sense it was solved when no energy was given to my laptop to keep anything in it. Until now I thought rebooting a computer was enough to clean the memory, but apparently not.

0

Another reason for not detecting Wifi after new installations or such issues might be a problem with Network Adapter Drivers.

You can first check which Wifi Network Adapter is there in your PC.

lshw -C network 

Mine Wireless N/W adapter was Realtek rtl8723be. So I installed the drivers from :

https://github.com/lwfinger/rtlwifi_new

Thanks.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.