4

My audio suddenly stopped working in Ubuntu 14.04 whilst I was playing something off Youtube. I restarted and purged pulseaudio and alsa, reinstalled both and pulseaudio-equaliser as well (which I have been using successfuly in 14.04 since the beginning).

The error output when trying to initialize pulseaudio is:

E: [pulseaudio] module-ladspa-sink.c: Master sink not found
E: [pulseaudio] module.c: Failed to load module "module-ladspa-sink" (argument:"sink_name=ladspa_output.mbeq_1197.mbeq master= plugin=mbeq_1197 label=mbeq control=-0.2,-0.2,-0.2,-0.2,3.5,3.5,3.5,3.5,3.5,3.5,3.5,2.5,2.5,0.0,0.0"): initialization failed.
E: [pulseaudio] main.c: Module load failed.
E: [pulseaudio] main.c: Failed to initialise daemon.

I have checked another thread with a similar question however the solution seemed to work for an older version of Ubuntu. I have tried that here as well with no luck. (Trying to remove the pulseaudio config files from /usr/etc/pulseaudio) Note: I have found no .pulse folder in my home directory to purge.

Thanks for any help in Advance.

  • Just a quick workaround: you can play YouTube videos in VLC and you can configure VLC to use ALSA instead of PulseAudio. – kraxor Jun 1 '14 at 21:25
  • Hi Kraxor, Thank you :). I forgot to mention my ALSA is working fine because audio actually plays from any program but I just don't have a way to control it from Ubuntu. Sound settings won't work because pulseaudio does not initialize when logged in. – Smod Jun 1 '14 at 21:29
  • You can use alsamixer to control volume levels. I know this doesn't answer your question and hope that someone with greater knowledge comes by. – kraxor Jun 1 '14 at 21:34
  • True! I just tried alsamixer it works and shows me all the levels and my soundcard options too. However when I use my arrowkeys the levels work but jump back to where they were. Am I doing something wrong? Thanks. – Smod Jun 1 '14 at 21:39
  • @Kraxor, correction: it works fine with alsamixer. Thank you, for now this will do, until somebody comes along with an answer for the above question. – Smod Jun 1 '14 at 22:05
11

For anybody that comes here in the future, there's a much easier solution to this problem as found here. It worked like a charm for me.

cd ~/.config
mv pulse/ pulse.bak/
pulseaudio --start
cp -rp pulse.bak/presets pulse/

You will see a bunch of errors about files in ~/.config/pulse/ not existing which you can ignore when you start pulseaudio. The presets folder will only exist if you have pulseaudio-equalizer installed (and maybe only if you've already set presets). It just stores your presets so it's not a huge deal either way, but it's nice to copy if you've already put work into your custom presets and want to keep them.

  • 1
    This is the answer that helped me! No one never mentioned that pulse folder in .config directory! Thank you! :) – HELU Mar 15 '16 at 7:46
  • worked like a charm! – Thiago França Jun 19 '17 at 16:48
7

Problem has been solved.

The location of the configuration file (which is altered by pulseaudio-equalizer) in Ubuntu 14.04 is ~/.config/pulse. After deleting this folder, I followed the following steps.

  1. I removed any traces of pulseaudio and pulseaudio-equalizer

    sudo apt-get purge pulseaudio pulseaudio-equalizer
    
  2. I physically removed any folders viz. /etc/pulse /usr/share/pulseaudio usr/share/pulseaudio-equalizer

  3. I performed a reboot

  4. I reinstalled pulseaudio and pulseaudio-equalizer (the equalizer install is optional!)

    sudo apt-get install pulseaudio
    sudo apt-get install pulseaudio-equalizer
    
  5. Note at this stage you will notice that your 'Ubuntu System Settings' has disappeared. So you have to reinstall the ubuntu desktop.

    sudo apt-get install ubuntu-desktop
    
  6. Also, note you can install ubuntu-desktop in the first place instead of pulseaudio because the removal of the latter removes the former and correctly so, the installation of the desktop covers pulseaudio install as well.

0

I also had a similar problem, and none of the above solved it. It turned out that in addition to reinstalling ubuntu-desktop, I had to remove my ~/.pulse folder.

It's not usually there, but I had created it while following some instructions online to solve some specific issues, and later I completely forgot about it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.