I recently installed Ubuntu 14.04 on my Lenovo Yoga 2 Pro and there is a problem with the touchpad. Whenever I lift my finger from the touchpad or click, the cursor moves a little bit to a random direction which makes me miss the target I wanted to click. This is very annoying and I couldn't find a solution online.

Can anyone tell me whether there is a solution to this problem and how would I fix it?

Thanks in advance.

  • From this link I found out that the pointer is only problematic when it is plugged. So, perhaps I have a faulty power supply as well. If yours is caused by the power supply as well, one hack is to keep your hand on keyboard or any metal part of your laptop. – Renaissains Jun 20 '18 at 17:02
  • Wouldn't using a grounded outlet and AC adapter be more effective than trying to find exposed metal on a current laptop? – Elder Geek Jun 21 '18 at 20:56

The simple initial approach would be to simply adjust your touchpad configuration, perhaps tun your sensitivity down, especially if it moves that much simply from taking your finger off the pad. Go to System Settings>Mouse and TouchPad> drag the bar next to TouchPad cursor speed to the left to turn down.

If the above option does not resolve the issue, see this link: http://memobadz.wordpress.com/2014/02/16/lenovo-yoga-pro-2-on-ubuntu/

which discusses several options for hardware configuration that you could explore. In reference to your issue, the section on Jumpy Touchpad and lack of middle button seems appropriate. Here is their suggestion:

Try creating the file /etc/X11/xorg.conf.d/50-synaptics.conf with this content:

Section "InputClass"
    Identifier "touchpad catchall"
    Driver "synaptics"
    MatchIsTouchpad "on"
    # This option is recommend on all Linux systems using evdev, but cannot be
    # enabled by default. See the following link for details:
    # http://who-t.blogspot.com/2010/11/how-to-ignore-configuration-errors.html
    MatchDevicePath "/dev/input/event*"

    Option "FingerLow"              "46"
    Option "FingerHigh"             "46"
    Option "ClickFinger1"           "1"
    Option "ClickFinger2"           "2"
    Option "ClickFinger3"           "3"
    Option "TapButton1"             "1"
    Option "TapButton2"             "2"
    Option "TapButton3"             "3"
    Option "AreaBottomEdge"         "85%"
    Option "SoftButtonAreas"        "60% 0 85% 0 40% 60% 85% 0" # Btn2 LRTB - Btn3 LRTB
    Option "EmulateMidButtonTime"   "75"

You can play with the values at runtime using synclient.


  1. To create above file, from command line:

    cd ~/Desktop             #changes your current directory to your Desktop for easy access
    touch 50-synaptics.conf  #creates file named 50-synaptics.conf
    gedit 50-synaptics.conf  #uses gedit(text editor) to open file
  2. Add the listed content to the file using gedit, then save and exit

  3. Make destination folder, from command line (#added line per comment from OP).

    sudo mkdir /etc/x11/xorg.conf.d
  4. To move file to appropriate folder, from command line

    sudo mv ~/Desktop/50-synaptics.conf /etc/X11/xorg.conf.d/ #Moves file from Desktop to target folder.

Good luck.

|improve this answer|||||
  • Could you elaborate on how to create and save the file /etc/X11/xorg.conf.d/50-synaptics.conf? – vicban3d Jun 2 '14 at 7:54
  • @vicban3d, see my Amended answer. – SonOfEntropy Jun 2 '14 at 15:37
  • That worked, thank you very much. Only thing is, I had to create the folder first with 'sudo mkdir xorg.conf.d' from /etc/X11/ and only then copy the file over. – vicban3d Jun 2 '14 at 16:16
  • 1
    @vicban3d, I see. I added the consolidated command per your comment for future users. – SonOfEntropy Jun 2 '14 at 17:01
  • 1
    If I am not mistaken, on Ubuntu post 10.04, the correct location is /usr/share/X11/xorg.conf.d/. Otherwise, the values you provided are perfect. Solved the unstable mouse on Lenovo IdeaPad Y50-70 flawlessly. – notan3xit Dec 25 '14 at 10:51

As for that problem on my Yoga 2 pro I had to type in bash

xinput --list

There you get a list of devices. From there you can see the devices. We want to display the SynPS/2 Synaptics TouchPad proporties.

xinput --list-props "SynPs/2 Synaptics Touchpad"

from there I edited the "finger" attribute up from 25 30 0 to 40 40 0 and that annoying last jump was gone.

 xinput --set-prop "SynPS/2 Synaptics TouchPad" 292 40 40 0

the 292 is the id in parenthesis next to the words "Synaptics Finger"

The following 3 numbers are

"FingerLow" -When finger pressure drops below this value, the driver counts it as a release.

"FingerHigh" - When finger pressure goes above this value, the driver counts it as a touch.

"FingerPress" - When finger pressure goes above this value, the driver counts it as a press.

The docs for the rest of the settings are here

|improve this answer|||||

If your pointer is shaking when you have a non moving finger on the touchpad. This solved it on my Yoga 2 Pro:

synclient HorizHysteresis=32 && synclient VertHysteresis=32
|improve this answer|||||

These answers have nothing to do with the question. There isn't a touchpad parameter for "amount to jump around randomly". Yes, most of us have tried changing the various sensitivities but that only changes how fast and how much pressure it takes...for the curse to jump around randomly.

To be clear, we're talking about the fact that Ideapads under Linux, when you simply touch the pad and leave your finger at the touch point, the cursor starts jumping around on the screen. Decrease the sensitivity and it takes more pressure before it starts jumping around.

None of these answers have anything to do with that. The bottom line is that IBM's taking over the hardware has MANY issues and seldom works right. Ever had it mute itself whilst reporting full volume? Dim the screen whilst reporting full brightness? These are all things where the IBM drivers are intercepting commands "to help you" with some "value added feature". Like most of those "features", it doesn't work right and you can't turn it off.

I have had some success cleaning under the space bar and alt key. It does this under Windoze as well and has been widely reported.

I've always known IBM laptops were prone to that. I've never seen it this bad though. Definitely my last IBM.

|improve this answer|||||

Not the answer you're looking for? Browse other questions tagged or ask your own question.