0

I'm a complete n00b to Ubuntu. I recently installed Ubuntu in the Parallels virtual machine (version 9) on OS X Mavericks. It was working fine for a while. Then it asked me if I wanted to update the system. I should have said no, apparently. I have deleted and reinstalled the virtual machine several times (including reinstalling the old version that worked before), but in each one I get a bug. At one point I had a launcher on the screen, but when I did anything the screen would flash white and nothing would happen. Most commonly, including in the current version (14.04 Mac), I have no launcher and no pull-down menus available. I can't even press Ctrl-Alt-T (or Cmd-Alt-T) to get a terminal. All I can do is access the shortcuts on my desktop, which take me to a file manager where I can't find any applications (including the terminal).

I'm not currently looking to use any apps. For now, I just want to get myself a damn terminal so I can compile things. I looked at this solution - Unity doesn't load, no Launcher, no Dash appears - and it doesn't work; pressing Ctrl-Alt-F1 at login appears to do nothing.

Should I deinstall Parallels entirely? Is there something else I can do?

1
  • Try ALT-CTL-fn-F1 for a terminal. I have the same but no solution yet.
    – David
    Jul 9, 2014 at 19:56

1 Answer 1

0

I'd imagine that because you're in a virtualised situation, all sorts of keyboard shortcuts aren't sent directly to the VM and/or they're being intercepted by OSX. I've very little experience with OSX and none with Parallels so I'm shooting in the dark but some Virtualisation host applications allow you to explicitly "send keys"

you may send keys to your virtual machine by choosing Devices -> Keyboard -> in the top menu for your virtual machine. (In older versions it should be Action -> Send Keys)

Use that to send a Control+Alt+F1 to Ubuntu and after that, it's back to the standard way of fixing things.


As you're only in this for a command-line interface, once you have a TTY, it might be worth installing the SSH server (sudo apt-get install ssh) and just sshing in from your OSX terminal.

1
  • Thank you. The Devices/Keyboard menu worked. So I get a terminal and I can now actually do stuff, which is the most important thing! It's not a very good terminal - I can't copy/paste and I keep having to press Ctrl-Alt to "release" the keyboard and mouse - but it'll do for now. The ssh option sounds appealing. If you don't mind another n00b question, how do I do that? I mean, obviously I type ssh at the OSX terminal, but what goes after that? What's the hostname? Jun 2, 2014 at 14:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.