16

How can I get Firefox to fully support html5 video?

The YouTube HTML5 Video Player says that H.264 and Media Source Extensions are not supported. Is there any way I can enable all of these?

19

Many of the features on that table are extremely new. The Media Source Extension spec, for example, is still a draft and is still being written. And it's being driven by Google and Netflix. It's going to take time for the spec to mature to a point where Mozilla want to spend any time implementing it.

h.264 support is somewhat easier (if you're on 12.04 - it's currently muddier if you're on 14.04):

sudo apt-get install ubuntu-restricted-extras

Update: In Firefox 30 (should be the default in all supported versions now), the feature is there but it's disabled by default. This should change in Firefox 31 but you can enable MSE by going to about:config (stick that in the address bar) and searching for mediasource. That should leave you with the media.mediasource.enabled option. Double click to enable.

On the Youtube panel the MSE & H.264 option is still crossed out... But the other two MSE options are now green.

  • FF 30 should become available in near future for 14.04 & it will support .h264 thru the gstreamer1.0-libav package. It's currently in utopic -proposed – doug Jun 1 '14 at 18:07
11

On top of the accepted answer, on Ubuntu 14.10 (FF 36.0) to obtain the OK for the MSE & H.264 you should set this properties to true on about:config:

  • media.fragmented-mp4.exposed=true
  • media.fragmented-mp4.ffmpeg.enabled=true
  • media.mediasource.mp4.enabled=true

Here you can find more details

3

All the steps above greatly helped me above, for anyone stuck, i have listed a "all in one" fix

1) Open terminal and enter sudo apt-get install ubuntu-restricted-extras

2) open firefox and enter about:config in the address bar, then search : mediasource

3) Change all listed values to True

4) search media.fragmented-mp4 again set the 3 values from the top to true

5) Right click and select New then Boolean

6) enter in the box media.mediasource.ignore_codecs in the next box select true then ok

7) go to youtube.com/html5 and enjoy green :D

1

You need to create a new preference to do so:

  1. Type about:config and hit enter.
  2. Confirm you will be careful.
  3. Right-click and select New > Boolean.
  4. Name the preference media.mediasource.ignore_codecs.
  5. Set its value to True.

If you go back to YouTube's HTML page, you should see all six technologies listed as supported

0

my firefox stopped playing recently. I had to turn media.fragmented-mp4.enabled to false to make it work again.

EDIT: I had perfectly running youtube via HTML5 for many months already, all codecs enabled. I managed to set it up based on internet posts but cant recall exactly how.

The post i write now is about recent situation that it stopped working, and video was not shown, except 240p and lower.. I did try various settings and finally found the reason - for my case:

All I had to do was to open about:config, search media.fragmented-mp4.enabled and change it to false.

  • This is kind of incomplete... – Star OS Dec 24 '15 at 8:33
  • 1
    Hi Coro, welcome to Ask Ubuntu. Can you include in your answer instructions on how to do that? Leaving a half-answer can often cause more harm than good. Thanks. – hg8 Dec 24 '15 at 9:00
0

Also check your browser add-ons! I fought this on a new install of Firefox in Mint up and down before I noticed a counter on an Add-On called Disconnect was really running up on a page that was giving me problems playing video. I white-listed the web page in the app and it worked fine!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.