47

The top panel and Unity launcher have disappeared in Ubuntu 14.04. Also cannot access the terminal via Ctrl+Alt+T.
I have tried every solution for this issue that I can find, from re-installing unity and compiz to resetting Unity and everything. I've gone into the compiz manager and reactivated Unity.
Nothing has worked.
When trying to reset Unity, or do anything with it really, I get this message

(process:6332): dconf-WARNING **: failed to commit changes to dconf: Could not connect: Connection refused



EDIT: Installed 14.04 a day ago. The issue happened after a reboot. After installing virtual Box

  • The exact same thing happened to me. Afraid to attempt re-installing virtualbox. Ever figure out why this happened? – Jay Soyer Oct 25 '14 at 3:26
  • 3
    Running export DISPLAY=:0 on a separate tty, following the procedure outlined in askubuntu.com/questions/457016/… to set the DBUS_SESSION_BUS_ADDRESS variable and finally running dconf reset -f /org/compiz/ did the trick for me. – Janaka Bandara Nov 27 '14 at 1:13
  • 1
    I'm also missing the launcher & menu bar, software-center is uninstalled, and I cannot open a terminal either through Ctrl-Alt-T nor Ctrl-Alt-F1-6. By booting into single-user mode (rEFInd), I automatically became root (without needing a password). This allowed me to create a new user and add them to the sudo group. I've now logged into the new account (where the GUI is fine) and have used su to get into my original account. I'm wondering if its possible to copy the GUI setup from the new user to my old one? If so, what should I copy? – gone Jul 31 '15 at 17:18
  • 3
    Same problem after installing Virtual Box... Solution export DISPLAY=:0 sudo dconf reset -f /org/compiz/ setsid unity – Djomla Oct 19 '15 at 9:39
  • @JanakaBandara how did you run the script in your link? What source do I have to specify? – Arch Stanton Dec 24 '15 at 12:40
44

Enter the following commands:- Ctrl+Alt+F1 login there with username and password

WARNING! THE FOLLOWING COMMAND WILL TERMINATE YOUR ACTIVE SESSION!

try:

sudo service lightdm restart

If restarting lightdm doesn't fix the problem, install aptitude and then install unity:

sudo apt-get install aptitude
sudo apt-get update && sudo aptitude -f install && sudo aptitude dist-upgrade
sudo aptitude install unity

Read the outputs carefully. If you do have broken dependencies, aptitude will give you the "solution" of NOT installing unity. Say no to this solution. Then it will give you another solution which will install broken dependencies. Say yes to this one. Once installation is complete, sudo service lightdm restart again. If you still have some issues, also reinstall ubuntu-desktop:

sudo apt-get install --reinstall ubuntu-desktop

followed by another sudo service lightdm restart.

(Credit to @DinGODzilla from this question)

  • 12
    Warning! This terminates the session. – Dror Feb 17 '15 at 12:30
  • 6
    I read the warning too late, god damn :D – red Apr 1 '15 at 7:55
  • Same problem as OP, but when I C-A-F1 (-F6) I get a blank screen. (No terminal.) What other options do I have? – gone Jul 31 '15 at 15:23
  • 1
    Ha, ha... Yeah, too late, it terminated my session, though my VPN connection is up. So, it does not free everything. – nephewtom Oct 5 '15 at 8:58
  • 1
    Same issue occurred on 16.04 and restarting lightdm service worked for me. – d a i s y Apr 22 '16 at 9:02
2

Hold down Alt-F2, which will bring up a dialog to enter terminal commands. There, type the command cinnamon-launcher and hit enter. That should restore the panel.

I am using Ubuntu 14.04

2

I have same issue in ubunt 14.04, i fix it by below steps

  1. ctrl+alt+f1
  2. enter username and password
  3. run mv ~/.config ~/.config_backup
  4. run sudo service lightdm restart

Hope it will work

  • Thank you. I've been trying things for a while and this is the first one that worked for me! – B.Adler Sep 17 at 22:37
0

I have similar issue with gnome panels. Instead of restarting lightdm which kills the session and closes the apps. I solve the issue by:

  1. Minimizing all the apps;
  2. Pressing Ctrl-Alt-Del (you might need to do it a couple of times);
  3. After 2. a popup asking to logout appears - close it or it would log you out.

The panels are back again. This trick always helps me when gnome panels disappear.

  • Not getting any popup in step 2....? – LoveToCode Aug 20 '16 at 8:38
  • Very much depends how your Ctrl-Alt-Del is setup... if it does a restart instead of opening a dialog, you know... – Alexis Wilke Feb 13 '18 at 1:26

Not the answer you're looking for? Browse other questions tagged or ask your own question.