3

Gimp launches every time I log into Xubuntu (v. 13.10).

Gimp is not shown under Settings Manager-> Sessions and startup.

It does not appear in ~/.config/autostart.

I immediately close Gimp in these cases, so it is not running when I shut down the session.

How do I stop Gimp from autolaunching on startup?


Diagnostic Info:

Note that

cd /
find . -name gimp.desktop 

Only produces

./usr/share/applications/gimp.desktop

and nothing else

Here is the output of grep -lIr 'gimp' ~/ > ~/Gimp-search-results.txt

sbin/vgimportclone
home/joshua/.gimp-2.8/controllerrc
home/joshua/.gimp-2.8/tags.xml

.....[edited for brevity]

home/joshua/.cache/oneconf/861c4e30b916e750f16fab5652ed5937/package_list_861c4e30b916e750f16fab5652ed5937
    home/joshua/.cache/sessions/xfwm4-23e853443-fb4b-42fd-aa61-33fa99fdc12c.state
    home/joshua/.cache/sessions/xfce4-session-athena:0
    home/joshua/.config/abiword/profile
  • 1
    have you tried to add it at the startup at any time? how did you implemented that? The possibilities of what is making the program tun are too many. It could be a script at system level, an entry on your bashrc, and everything between one and the other. – Rho Jun 1 '14 at 6:16
  • ok, raw approach: open a terminal and type locate gimp.desktop ...the results shouldn't be outside usr/share – Rho Jun 1 '14 at 6:41
  • Note that find . -name gimp.desktop in base dir only produces ./usr/share/applications/gimp.desktop and nothing else – Joshua Fox Jun 1 '14 at 9:44
  • Please run grep -lIr 'gimp' ~/ > ~/Gimp-search-results.txt and add the output to your question. – TuKsn Jun 1 '14 at 9:50
  • @Rho I edited the post to state where gimp.desktop is found – Joshua Fox Jun 1 '14 at 13:04
1

Ok it look like gimp is saved in your session cache.

.cache/sessions/xfwm4-23e853443-fb4b-42fd-aa61-33fa99fdc12c.state
.cache/sessions/xfce4-session-athena:0

Try this:

enter image description here

Press "Clear saved session"

Then be sure gimp is not open and restart.

2
  • In settings Manager-> Sessions and startup , try to activate "remember last session", then close Gimp and the session.
  • At next login, it should be ok, so you can unselect "remember last session".

If still getting problems, look here :
How can I stop the Ubuntu Software Center from autostarting in Xubuntu?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.