When I run sudo bash configure (./configure doesn't work), I get this:

checking whether we are cross compiling... configure: error: in /media/pitaj/Shared/Documents/makeMKV/makemkv-oss': configure: error: cannot run C compiled programs. If you meant to cross compile, use --host'. See `config.log' for more details

In console.log, it says that gcc -V isn't valid

I'm following this tutorial: http://www.makemkv.com/forum2/viewtopic.php?f=3&t=224

1 Answer 1


Most likely the folder you are compiling on is mounted with the noexec option. For security reasons, tmpfs under /tmp is mounted noexec.

Move the entire folder to a mount that can execute programs or remount the place with different options. Background: The configure script needs to perform some basic tests which also involve compiling and running the compiled test program.

  • You were right. I had the files on an NTFS partition. Moved them to my main partition, and it worked like a charm.
    – PitaJ
    May 31, 2014 at 22:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.