I tried to update the nvidia drivers using:

sudo add-apt-repository ppa:ubuntu-x-swat/x-updates
sudo apt-get update
sudo apt-get install nvidia-current

After this, I rebooted my pc, launch Ubuntu, then I can see that it's loading everything (as usual), but then I end up with a black screen and a flashing underscore. (I tried to load the terminal at this point using ctrl + alt + F1, but that doesn't work)

My videocard model is GT650M

How can I fix this?

  • what is your video card model? why were you using X-swat ppa ? The nvidia driver on Ubuntu 14.04 works well, it's not the newest but it's good and stable. There's a bit problem with manual installing of not proprietary video drivers on 14.04 yet, there's incompatibility with newer linux kernels, but I guess it will go away soon, with time. – JoKeR May 31 '14 at 14:38
  • can you get to a Login Screen? if not I'll help you don't worry but you gotta have internet connection on your machine, if you have it's ok. – JoKeR May 31 '14 at 14:42
  • I'm using a GT650M. Why was I using 'X-swat ppa'? Well I'm quite new to using Linux and I googled how to update the Nvidia drivers and the first site suggested to use the commands as stated in my post... – user287144 May 31 '14 at 14:43
  • so can you get to Login Screen? or reboot in FailSafe mode press and hold Shift during reboot – JoKeR May 31 '14 at 14:45
  • What do you mean by getting to a Login screen? I've enabled ubuntu to log me in automatically, so before this problem I never used a login screen. – user287144 May 31 '14 at 14:48

To remove the obviously non-working driver, which will get you back to the previous stage:

  1. Boot to a root shell
  2. Install ppa-purge to remove the x-updates ppa:

    apt-get update && apt-get install ppa-purge
    ppa-purge ppa:ubuntu-x-swat/x-updates
    
  3. Reboot

    reboot
    

This should replace the updated nvidia-current driver with the version from the repositories.

Alternatively (or if you don't trust ppa-purge) you can also purge the nvidia-current driver, remove the ppa, and then reinstall the proprietary driver from the repositories from within a root-shell:

apt-get purge nvidia-current
add-apt-repository --remove ppa:ubuntu-x-swat/x-updates
apt-get update
apt-get install nvidia-current

Note: no sudo needed in the root shell

  • I solved it, finally! by going to the rootshell, establish a connection and mount the drive. Then I used apt-get purge nvidia-* and then wget http://us.download.nvidia.com/XFree86/Linux-x86_64/331.67/NVIDIA-Linux-x86_64-331.67.run chmod +x NVIDIA-Linux-x86_64-331.67.run sh ./NVIDIA-Linux-x86_64-331.67.run. The problem was that most drivers do not support my graphics card. @Takkat, @JohnnyEnglish Thanks for helping me! – user287144 Jun 1 '14 at 8:35
  • Glad you sorted it out! As you now had not installed the driver from repos or ppa it may be that you will have to manually update the driver after each kernel update (piece of cake, now that you know how to do that). Watch out for updates in the x-swat/x-updates ppa (at present they have the 331.20 driver there). – Takkat Jun 1 '14 at 9:16

To fix a similar issue with 16.04 and nvidia-375 I did the following:

  • Pressed Shift to get access GRUB menu Logged into recovery mode (I had to use previous kernel version)
  • Enabled networking
  • Accessed root shell
  • Typed the following to help me identify which package I needed to uninstall

ubuntu-drivers devices

  • Typed the following to uninstall the driver package

apt-get purge nvidia-375

Then I was able to restart and boot regularly. Phew!

you can remove them by first finding out their name with

ubuntu-drivers list

that will tell you their names. Then you can use

sudo apt-get remove *******

to remove any of them that are installed.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.