2

hello all i have Asus x550cc laptop with ath9k wifi card in which I have a problem with Ubuntu 14.04. i can not enable wifi it shows wifi is disabled by WiFi switch I tries 'rfkill list all' command it shows wireless Lan hard blocked yes. I have no physical button in my comp for wifi all I know is alt+F2 for enabling disabling wifi pls help.

1
4

Is the module asus_nb_wmi loaded? Check:

lsmod | grep asus

If so, try a temporary fix:

sudo modprobe -r asus_nb_wmi
sudo modprobe asus_nb_wmi wapf=1 
sudo rfkill unblock all
rfkill list all

Any improvement? If so, make the driver parameter permanent:

sudo -i
echo "options asus_nb_wmi wapf=1" | sudo tee /etc/modprobe.d/asus_nb_wmi.conf
exit

If the parameter 1 is ineffective, we can also try 0 and 4.

4
  • hi thanks for your replay but sudo modprob doest work. the rfkill list all shows 0: hci0: Bluetooth Soft blocked: no Hard blocked: no 1: phy0: Wireless LAN Soft blocked: no Hard blocked: yes 6: asus-wlan: Wireless LAN Soft blocked: no Hard blocked: no 7: asus-bluetooth: Bluetooth Soft blocked: no Hard blocked: no – neeraj_nigam May 31 '14 at 13:01
  • What is the error or message with modprobe? Did you confirm that asus_nb_wmi is loaded or no? – chili555 May 31 '14 at 14:16
  • hii there i dont know how but when i put my pc on sleep for once my wifi start working normally... but for every boot i have to repeat this method every time ... is there any solution?.. and also when my wifi light turned on it can not work but when it is off my wifi start working?? – neeraj_nigam May 31 '14 at 17:46
  • Did you confirm that asus_nb_wmi is loaded or no? – chili555 May 31 '14 at 21:35
1

To turn Wireless ON when your systeem starts up do the following:

Open a Terminal (CTRL+ALT+T).

Enter the following line only if you don't have gksu installed.

sudo apt-get install gksu -y

If you have GKSU (installed or already have) enter the following:

gksudo gedit /etc/rc.local

The rc.local fill will open up, add the following line before the exit 0:

rfkill unblock wireless

Now enter the following line in a terminal:

sudo reboot


To turn Bluetooth OFF when your systeem starts up do the following:

Open a Terminal (CTRL+ALT+T).

Enter the following line only if you don't have gksu installed.

sudo apt-get install gksu -y

If you have GKSU (installed or already have) enter the following:

gksudo gedit /etc/rc.local

The rc.local fill will open up, add the following line before the exit 0:

rfkill block wireless

Now enter the following line in a terminal:

sudo reboot


To switch between ON or OFF you can use the FN+Wireless key on your keyboard. This key is different for each system. You can change wireless also for something else, like bluetooth.

1

I have installed Linux Mint on my Asus X550C and I have found a way to enable wireless! I will write what I've done:

Terminal:

lspci -nnk | grep -A2 0280

Bash answer: ...

...
Kernel driver in use: ath9k

lsmod | grep -e ath9k -e asus

Bash answer: ... ... asus_nb_wmi ...

Check if you find asus_nb_wmi in the output!

rfkill list all

See if "Hard blocked: yes".

Suspend the notebook by pressing Fn+F1 then resume it again and wireless will be enabled!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.