Bumblebee stopped working on my system after upgrading to stable version of Ubuntu 14.04.

DUring installation I get this error rmmod: ERROR: Module nouveau is in use

Setting up bumblebee (3.2.1-90~trustyppa1) ...
Selecting 01:00:0 as discrete nvidia card. If this is incorrect,
edit the BusID line in /etc/bumblebee/xorg.conf.nouveau .
bumblebeed start/running, process 11133
Processing triggers for initramfs-tools (0.103ubuntu4.1) ...
update-initramfs: Generating /boot/initrd.img-3.14.1-031401-generic
Setting up bumblebee-nvidia (3.2.1-90~trustyppa1) ...
Selecting 01:00:0 as discrete nvidia card. If this is incorrect,
edit the BusID line in /etc/bumblebee/xorg.conf.nvidia
rmmod: ERROR: Module nouveau is in use
bumblebeed start/running, process 18284

It says nouveau is in use. I checked the loaded modules

 lsmod | grep nouveau
nouveau              1097199  1 
mxm_wmi                13021  1 nouveau
ttm                    85115  1 nouveau
i2c_algo_bit           13413  2 i915,nouveau
drm_kms_helper         52758  2 i915,nouveau
drm                   302817  7 ttm,i915,drm_kms_helper,nouveau
wmi                    19177  3 dell_wmi,mxm_wmi,nouveau
video                  19476  2 i915,nouveau

However, I have nouveau in my blacklist

cat /etc/modprobe.d/blacklist.conf | grep nouveau
blacklist nouveau
blacklist lbm-nouveau
alias nouveau off
alias lbm-nouveau off

My grub is also set to nomodeset

cat /etc/default/grub  | grep nomodeset
GRUB_CMDLINE_LINUX_DEFAULT="nomodeset quiet splash"

My graphics card is nvidia optimus

lspci | grep -i vga
00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 18)
01:00.0 VGA compatible controller: NVIDIA Corporation GT218M [GeForce 310M] (rev ff)

I've raised a bug in launchpad: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1327598

Note: Nvidia-prime is working for me (partially). Frequent mouse locks. Interestingly, bumblebee works perfectly fine on my fedora 20 partition on this same laptop.

  • Have you tried the line options nouveau modeset=0 in your blacklist? Failing that, have you tried using the bumblebee-nouveau package to have bumblebee work with the nouveau driver
    – Jon Hanna
    Oct 7, 2014 at 21:13

2 Answers 2


Ubuntu has support for Nvidia Optimus out of the box via a solution that works a lot faster than Bumblebee. It is done using the "nvidia-prime" package which is a native solution to switch between Nvidia or Intel graphics.

To use it however, you need the Nvidia Proprietary drivers. (just look for them in the additional drivers tab in Ubuntu). Once installed, look for "Nvidia PRIME" in the Nvidia Settings manager.

  • That is absolutely wrong. Ubuntu does not support optimus "out of the box". Nvidia-prime is not installed by default. Plus unlike bumblebee, you have to logout and log back in.
    – Ubuntuser
    Jun 5, 2014 at 14:52
  • Well, recent Ubuntu versions certainly do support Optimus out of the box, if the card is supported by Nouveau - no need for a separate package. Whether you consider "out of the box" to mean "just install the correct package" or "is installed by default" is down to personal feeling. I'd tend to fall down the line that if there's a package for it in the supported base set, then it is supported "out of the box".
    – karora
    Feb 13, 2016 at 16:06

Over time, as Nvidia cards become better supported by the Nouveau drive they often become unsupported by the proprietary driver. This happened for me recently, when bumblebee and all of my 3d setup disappeared from the proprietary driver and I was forced to switch to Nouveau, which supports Optimus natively - there are some details on Optimus and Nouveau featureset at nouveau.freedesktop.org.

The GeForce 310M seems to be of a vintage which this would also apply to, but I can't categorically say that for certain.

I found this was the case by removing the nouveau module, modprobing the nvidia module in its place and then checking the output of 'dmesg'. Obviously I did all this without X running!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .