I have a problem with HPLIP on Ubuntu 14.04LTS.

After upgrading to Ubutntu 14.04 LTS my HP LaserJet 1018 stopped printing (code=12).

I found several issues with printitng and HPLIP so I was able to troubleshoot this. The steps I took were :

  1. Reran HPdoctor
  2. Ran hp-check
  3. Un-installed and installed the latest version of HPLIP (3.14.4)
  4. Checked the USB connections lsusb and lsusb-v
  5. Re-ran hpcheck
  6. Removed the printer from HPLIP
  7. Re-ran hpcheck
  8. Manually configued HPLIP to the printer hp-setup-g <xxx:yyy>

It broke again later, now HPLIP can't see the printer but lsusb can.
Initially thought this may be due to usb given a new bus/device after being turned on and off and went to repeat the steps above at the moment still seeing an error in that the HPLIP is complaining that it cannot see the device

**error: Device not found. Please make sure your printer is properly connected and powered-on.**

lsusb output:

Bus 002 Device 007: ID 03f0:4117 Hewlett-Packard LaserJet 1018

sudo hp-check output

hp-setup -g 002:007 output:

window box "device not found  please make sure your printer is properly connected     and powered on"
> hp-setup[18461]: debug: param=002:007 hp-setup[18461]: debug:
> selected_device_name=None Fontconfig error:
> "/etc/fonts/conf.d/65-khmer.conf", line 14: out of memory Fontconfig
> error: "/etc/fonts/conf.d/65-khmer.conf", line 23: out of memory
> Fontconfig error: "/etc/fonts/conf.d/65-khmer.conf", line 32: out of
> memory hp-setup[18461]: debug: Sys.argv=['/usr/bin/hp-setup', '-g',
> '002:007'] printer_name=None param=002:007 jd_port=1 device_uri=None
> remove=False Searching for device... hp-setup[18461]: debug: Trying
> USB with bus=002 dev=007... hp-setup[18461]: debug: Not found.
> hp-setup[18461]: debug: Trying serial number 002:007 hp-setup[18461]:
> debug: Probing bus: usb hp-setup[18461]: debug: Probing bus: par
> error:  Device not found.   Please make sure your printer is properly
> connected and powered-on. hp-setup[18461]: debug: Starting GUI loop.

Is this a Bug with HPLIP or an issue with laptop/printer?
How can I fix this or report it, if it is a bug?

  • It is bug in ubuntu 14.04: bugs.launchpad.net/hplip/+bug/1315408 Consider to vote and contribute. – Arie Skliarouk Jun 26 '14 at 15:08
  • 1
    These problems are perfectly understandable, considering printing technology have only been around for a couple of years. – opyate Mar 2 '15 at 9:41

I experienced similar problems, as cited in this forum, trying to configure the HP Laserjet 1018 printer with ubuntu desktop 14.04 and 14.10. At the begining I used HPLIP installed manually, and the printer worked fine for a while, I was able to print 3 or 4 documents, but then the printer started to fail with "communication error". After some combinations of unplug and re-plug, turn off on or reboot the printer works again, but this is an annoying situation, specially because I wanted to make the printer works for common users without any knowledge.

So I decided to try the solution installing the foo2zjs driver, these are the steps I followed, after reading many forums and potential solutions:

  1. Uninstall HPLIP completely

    1. Uninstall HPLIP if it was installed by default in ubuntu

      sudo apt-get remove hplip
    2. In my case, I had installed HPLIP manually, after downloading the tarball distribution from http://hplipopensource.com/hplip-web/index.html. So I followed the instructions cited here to completely uninstall it.

  2. Install the foo2zjs driver, to do this I used the instructions cited here. I transcribe them here:

    1. Install build-essential, tix, foomatic-filters, groff, dc FIRST:

      sudo apt-get install build-essential tix foomatic-filters groff dc
    2. Unpack:

      wget -O foo2zjs.tar.gz http://foo2zjs.rkkda.com/foo2zjs.tar.gz
      tar zxf foo2zjs.tar.gz
      cd foo2zjs
    3. Compile:

    4. Get extra files from the web, such as .ICM profiles (for color correction) and firmware. Select the model number for your printer, In this case:

      ./getweb 1018      # Get HP LaserJet 1018 firmware file
    5. Install driver, foomatic XML files, PPD files, and extra files:

      sudo make install
    6. Install hotplug (for HP LJ 1000/1005/1018/1020/P100[5678]/P1505):

      sudo make install-hotplug

    Unplug and re-plug the USB printer

    1. If you use CUPS to manage your printers, you must restart cupsd:

      sudo make cups
  3. Add a new printer by pasting http://localhost:631 in your browser address field and adding a new printer. Once created it, print a test page.

In my case I experienced problems using cups, so I reinstalled it with

sudo apt-get -y install cups

NOTE: I suggest to watch the log /var/log/syslog to detect any possible error. For example, after installing foo2zjs, I detect the following error in syslog:

foo2zjs: Missing HP LaserJet 1018 firmware file /lib/firmware/hp/sihp1018.dl

So, I fixed it by getting the firmware:

getweb 1018

Then I copied the file sihp1018.dl to the directory specified in the syslog error.

You may need to reboot both the computer and the printer.

After these steps I was able to print using the HP LaserJet 1018 printer without problems, I did different tests like print a test page, print a LibreOffice doc, print a PDF doc. I reboot the machine and printed again and the printer worked perfectly. I tested using both Ubuntu 14.04 and 14.10.

Hope this can help.

  • Worked for me in Ubuntu 16.04 as well, thanks! – jotadepicas Sep 9 '17 at 23:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.