9

I have the dropbox missing icon display problem.

I try solutions like "sudo apt-get install libappindicator1", removing all the package and dropbox directories, reinstalling and no icon shows up.

the dropbox daemon works and update the directory without problem.

this is strange since, I use 2 different ubuntu 12.04 installations, one show up the dropbox icon fine and the second do not.

thanks

  • I have the same problem: on the same machine and same OS, for one user it works fine, for another it doesn't. I suspect it is some tray icon display problem, not necessarily related to Unity – jj_p Jun 24 '14 at 11:27
  • 1
    I have the exac same problem: two machines with Ubuntu 12.04 and gnome classic, one both up to date, one of them works well, the other does not show the icon (just a single dot). It is Dropbox 3.0.4. None of the above solutions worked. – Alejandro DC Jan 9 '15 at 1:06
  • I also see "the dot" instead of an icon (Ubuntu 14.04). It is at least possible to access the Dropbox menu by (carefully) right-clicking exactly one pixel to-the-left-of or above the dot (depending on your panel orientation). Has this been reported to dropbox? (anyone have a link?) – Mark Jan 16 '15 at 15:27
8

Same problem for me... I solved by typing in a terminal:

dropbox stop
dropbox start

I have not rebooted the pc yet so I don't know if this solution works also after rebooting but for now I have the icon working. If you want type also:

dropbox autostart y
7

I had this Problem and none of the above worked for me. However the solution was simple. Im using the gnome classic environment,hold Alt + WinKey whilst you right click on panel.select Add to panel and add NOTIFICATION AREA. Voilla Dropbox Icon appears Hope this can help someone

3

If you are sure everything is installed correctly, you should run in a terminal:

gsettings get com.canonical.Unity.Panel systray-whitelist

The output will be a list, looking like:

['item1', 'item2']

Dropbox will probably not be in it. Edit the list in (for example) gedit, adding 'dropbox' to the list, and run in a terminal:

gsettings set com.canonical.Unity.Panel systray-whitelist "['item1', 'item2', 'dropbox']"

After log out / log in, the Dropbox icon should be in the tray again.

  • This did not work on 12.04 with dual monitors. An icon showed up on one monitor but it did not look or function correctly. – Antonios Hadjigeorgalis Jul 19 '14 at 15:57
  • 1
    @Antonios You describe another problem, which probably has nothing to do with op's problem. I suggest you ask another question instead of downvoting a correct answer to this question. – Jacob Vlijm Jul 19 '14 at 21:41
  • your solution makes an icon show up but it does not solve the op's problem. The icon that shows up is not the same as the icon that shows up when the dropbox daemon is stopped and restarted. It does not function the same either. – Antonios Hadjigeorgalis Jul 20 '14 at 16:29
  • Not sure why it didnt work for others but it did for me and I didnt need to logout, just adding 'dropbox' to the whitelist while it was stopped (via cli 'dropbox stop') and then running dropbox start brought the tray icon back for me. – Maks Jul 23 '14 at 23:47
  • @Maks If you stop and restart the daemon the icon shows up correctly even if you do not add 'dropbox' to the whitelist – Antonios Hadjigeorgalis Jul 25 '14 at 12:59

protected by Community Jul 7 '14 at 19:53

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.