0

Ive noticed a really annoying behaviour in Ubuntu: whenever I restart or shutdown the PC from a Live session, the USB stick becomes unavaliable when it reboots/turns on (as if the "safe removal" feature from windows was used)

Ive noticed this in 10.04, 10.10, 11.04, and even Linux Mint 10 and 11. Also happens with all USB sticks Ive tried (like 4 different models), in all machines (tested in like 5). So I think this is rather a feature than a bug/hardware issue.

But its really annoying. After playing in a Live Session, i must physically unplug-and-replug the USB stick so it works again.

Is there any way to disable this behaviour? So I can reboot my PC and use the Live Session again without unplugging and replugging the USB stick?

2
  • Are you rebooting back into the LiveCD environment? I don't think LiveCD will automatically mount any drives on startup, be they fixed or usb. – drgrog Jun 7 '11 at 12:54
  • It doesnt reboot back to Live enviroment because the USB stick is somehow "disabled" when i shut down (or reboot) the Live session. I have to unplug and replug it again for it to work, which is annoying. – MestreLion Jun 7 '11 at 13:44
0

For those who might be interested, I've found the culprit: When you shutdown a live session, Ubuntu ejects its media. for an USB stick, this means powering down the USB port.

A workaround is to edit /boot/grub/grub.cfg, and change the line:

linux /casper/vmlinuz file=/cdrom/preseed/ubuntu.seed boot=casper quiet splash --

to add the parameter noeject (noprompt is also useful, so it does not ask for ENTER to eject CD when shutting down)

Like this:

linux /casper/vmlinuz file=/cdrom/preseed/ubuntu.seed boot=casper quiet splash noeject noprompt --

Presto :D

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.