1

After installing new kernel update unity is not loading. Just blank screen without Unity panel. I have tried to delete Unity and Compiz config files, and to reinstall Unity, but there is no result. I also tried to boot with older kernel, but there is the same situation with unity. If in terminal (Ctrl+Alt+F1) try to run unity command, then will be message

 WARNING: no DISPLAY variable set, setting it to :0

I also checked if the video driver installed by runing lshw -c video, and the driver was mentioned there. How to solve this problem? Maybe I need to reinstall video driver (but I don't know how to reinstall built-in driver for my Intel HD Graphics 4000), or maybe something wrong with xorg...

0

Open the console by the following keys:

CTRL+ALT+F1

Then do the following:

Use this to Remove/Uninstall Compiz Unity:

sudo apt-get remove compizconfig-settings-manager
sudo apt-get remove compiz-fusion-plugins-extra
sudo apt-get remove compiz-plugins-extra
sudo apt-get purge compiz*

Then to Re-install Compiz Unity use:

sudo apt-get install unity-2d
sudo apt-get install ubuntu-desktop
sudo apt-get install ubuntu-desktop-2d
sudo apt-get install compizconfig-settings-manager
sudo apt-get install xserver-xgl
sudo apt-get install emerald
sudo apt-get install compiz-fusion-plugins-extra
sudo apt-get install git compiz-plugins-extra
sudo apt-get install compiz-plugins-extra
sudo apt-get install unity
| improve this answer | |
  • Am I need to install unity 2D? – Ilia May 30 '14 at 14:30
  • No, you can just choose what you want. – Korkel May 30 '14 at 14:34
  • It seems that I have to remove ubuntu-desktop, unity, xserver-xlg before installing these packages? – Ilia May 30 '14 at 14:39
  • I suggest you to do. – Korkel May 30 '14 at 14:41
  • No result. Unity still not working. When I was runing sudo apt-get purge compiz*, near the end of output I got (gconftool-2:4185): GConf-WARNING **:Client failed to connect to the D-BUS daemon: Unable to autolaunch a dbus-daemon without a $DISPLAY for X11 – Ilia May 30 '14 at 15:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.