I'm using Xubuntu 11.04. Before everything worked fine, but when booting today the following happened:

  1. Window focus does not leave the first-opened program. This means that if I keep Firefox open, and open a terminal, window focus will never be transferred to the terminal.

    (EDIT: if I open a terminal first, and then open Firefox, Firefox steals focus)

  2. Window menus have disappeared. The maximize, minimize, etc., buttons and menu are gone.

  3. In Xfce Settings Manager, the "Window Manager" settings window is empty. There is just a gray screen there, so I cannot modify any window settings.

  4. The keyboard shortcuts I had previously defined using the Settings Manager do no longer work. Further, ALT-TAB no longer works for cycling between windows.

  5. The mouse pointer does not show when I first log in. I have to log out and log in again (with an invisible pointer) before the mouse shows itself.


  6. I cannot re-size or move the Thunderbird window, but I can move the Firefox window

What can I do to troubleshoot this?


3 Answers 3


You need to have the program xfwm4 run on startup.

To do that, add a program to the login items.

To add a program to the login items, open up the session editor (Applications Menu > Settings > Session and Startup), switch to the "Application Autostart" tab, and then add a new item:

enter image description here

Click "OK", and you should be good to go.

Also, if you could file a bug (For more on how to do that take a look here) that'd be great.

  • 2
    No worries about the desktop settings, they were quickly restored. I'm granting you the answer because it points to the culprit -- xfwm4, the window manager. However, I managed to avoid starting it manually. Just started it once, then deleted the contents of ~/.cache/sessions/, and it now starts by itself. Hopefully this will be of help to other people. Jun 9, 2011 at 14:29

I have found steps that fix the bug without any hacks:

  • delete the content of ~/.cache/sessions/
  • remove additional startup item for xfwm4 (if created as suggested by 'jrg')
  • reboot PC

These steps were suggested to me when I reported the bug https://bugs.launchpad.net/ubuntu/+source/xfce4-session/+bug/1277738

  • Deleting the content of ~/.cache/sessions/ did the trick with me. Jan 3, 2015 at 23:15

I had and solved the problem in Xubuntu 12.04. Running xfwm4 from the Run Program dialog (Alt+F2) solved the problem.

  • You'll probably want it to run for every session, though, so adding it to your login items is probably preferable to manually running the xfwm4 command every time. Mar 28, 2013 at 22:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.