0

I want to use a system wide proxy and did the following:

Created a file apt.conf in etc/apt/

with

Acquire::http::proxy "http://user:pass@proxy.pac:8012/";

(I had to set chmod to 777 to edit it)

I put the same line in etc/environment.

I put the proxy in network administration.

It still doesn't work.

The proxy works fine when I put it in firefox.

Any other ideas?

Nothing from these answers worked for me: Proxy settings not working

Thanks

Update: If I run the command set | grep -i proxy

I get the following:

http_proxy=http://http://my_user_pass@proxy:8012/

no_proxy=localhost,127.0.0.0/8,::1

  -p --http-proxy --no-http-proxy\
0

Run this command

sudo gedit /etc/apt/apt.cong


input your password:
And set all your proxy setting as edit this section:

Acquire::http::proxy "http://user:pass@proxy.pac:8012/";

And save this and close. Now you can work fine.


You must set your proxy setting from Network and set setting as manual to create apt.conf file in this location /etc/apt/apt.conf

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.