I used to use my ps3 controller to play games, and a couple of days ago it stopped working. I get this message during boot up (after BIOS):

[ (some numers)] sony 0003.054c.(more numbers): can't set operational mode

qtsixa still recognizes the controller being plugged in. My best guess is there was an update to a dependent or repository or something.

I also tried to connect a different ps3 controller with a different cord in a different USB slot - no change. I have also tried resetting them both with the little button on the back.

I entered lsusb in terminal and in usb port 7 it says:

Sony Corp. Batoh Device / PlayStation 3 Controller

Jstest & antimicro don't recognize that the controller is there.

  • I am having this problem too, if you are on 14.04 it is the kernel update from a couple days ago that caused this. Booting in to the older kernel makes it work for me, but I can't figure out how to get it working in the new one. I've tried reinstalling sixad and its dependencies. – user288104 Jun 3 '14 at 17:24
  • AHHH I'm so glad I'm not the only one! I barely know what a kernal is, much less how to switch them. To fix it I re installed 14.04, and I'm not updating. We need someone who knows better. Meybe there's a correlation! What system are you running? – FormicSapien Jun 4 '14 at 21:00

Hu guys, the problem is a bug in Linux kernel:


Please add more info or subscribe to that bug to be acknowledged of any progress.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.