1

I am a newbie in setting up Ubuntu MAAS. I did the following.

I setup MAAS Server using Ubuntu 14.04 Trusty - MAAS Server Install. I did post-install tasks like creating logins, importing boot images as explained here:

I have the boot images in the list for Cluster master.

Problem A: I would like to add nodes to my MAAS server. So, I did the following:

  1. On a second computer, I Booted the same CD, went through the steps, and at the MAAS step - I specified MAAS server address - it just "Sent SIGKILL to all process. Requesting power off"
  2. Via the web interface, I added the node. I added the information needed. One part I did not know was the Power type. I just selected Wake-on LAN and gave the same Mac address as that on the computer. Is this even correct? If not, what do I need to give?

After 2, I did 1. again - still same problem.

Problem B: In Web Interface, it says it is commissioning for the node for a long term. Any action I try to do, it says "The action "Commission selected nodes" could not be performed on 1 node because its state does not allow that action."

Any suggestions are appreciated.

5
+100

If you haven't already, you need to configure the cluster to manage DHCP and DNS on the network that the new nodes are going to be on. You can find instructions for that here.

Once DHCP is configured, you can delete the existing node (it's easier to start with a clean slate). The simplest way to add a new node to a MAAS cluster is as follows:

  1. In the node's BIOS, change the boot order so that it boots from the LAN first. This will allow it to PXE boot from the MAAS cluster controller.
  2. Power the node on. You don't need to have a CD in the machine; it should boot from the network.
  3. Once the node has booted from the network it will show up in MAAS as "declared". You can then accept the node into your MAAS and begin the commissioning process.

The full instructions for adding new nodes can be found here

As far as your second problem is concerned, I think this is down to two things:

  1. An incorrect power type (if you don't have a specific power controller for the node then Wake-on-LAN makes sense, but if the node's not configured to Wake-on-LAN it won't work).
  2. MAAS hasn't actually seen the node on the network yet.

If you follow the procedure above, the node should show up in MAAS automatically, without you having to add it manually.

5
  • Additionally, I think the SIGKILL output is expected behaviour- once the node has contacted the MAAS controller it will power down – Nick Veitch Jun 2 '14 at 14:01
  • I appreciate your help! – user1680784 Jun 3 '14 at 14:00
  • Unfortunately, IT dept. might not let me have my own DHCP server running. I referred the same docs, which talks about adding nodes in this condition - but, still left clueless. Is PXE boot necessary to get it added to cluster? I have another Ubuntu 14.04 Server, can I add this to the cluster? I tried to add this manually via Web Interface, but still problem B exists - it still says commissioning, and prints the same error message. – user1680784 Jun 3 '14 at 14:07
  • Is there way to build MAAS ISO, similar to Cobbler ISO? cobblerd.org/manuals/2.6.0/3/2/6_-_Build_ISO.html – user1680784 Jun 4 '14 at 19:00
  • Well done, that worked for me. Dell Vostro 200 as node. The PXE boot option was well-hidden. Had to do a BIOS boot with F2 -> Integrated Peripherals -> Onboard LAN Boot ROM = Enabled -> Save/Exit, F12 on reboot to set "IBA GE SLOT 00C8" as the primary boot which is presumably the PXE ROM. Cheers. – Michael Blankenship Aug 20 '15 at 20:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.