-1

Getting straight to the point, I am trying to install Ubuntu 14.04 LTS alongside a pre-installed Windows 8 (now updated to 8.1). I am a newbie (even though I used Linux and Ubuntu for some time now, I still see myself as a newbie), so I would appreciate as much help and clarity as I can get.

I am using a Toshiba Satellite L850-1L1 Laptop with the following specs

· Processor Intel(R) Core(TM) i7-3630QM CPU @ 2.40 GHz

· 8 GB RAM

· 64 bit Operating System, x64-based processor

· 1 TB HDD (No SSD), GPT Partitioning scheme (GUID Partition Table)

· System BIOS Version 6.7 / EC Version 6.00 (no idea if this bit of info will help or not)

I removed about 60 GB of the C partition that has windows. I left it as a new unallocated volume (I left it as free unpartitioned and unformatted space). As for the Secure Boot and UEFI settings in the BIOS, I left them enabled (since I read in ask Ubuntu that it is always better to try installing with both options enabled) and shut down the laptop. Something worth mentioning, I read an article that said I should switch to CSM Mode before shutting down and then install Ubuntu; I did not do that. When I change the boot manager from UEFI to CSM Boot, it does not boot anything coz of copyright issues. Plus, Ubuntu boots in legacy mode and not UEFI Mode.

With try Ubuntu I was able to boot the live version without problems, then started installing Ubuntu and when I got to the system installation window there was no option that said “install alongside windows 8”. So I picked “something else”, made a 5.77 GB partition (read somewhere that it is supposed to be 10% the size of the main system partition) for swap area and 51.22 GB for booting the main system ( / ). After Installation GRUB menu opened and I could open Ubuntu without problems but with windows, it gave me an error and did not want to boot it. I ran boot repair and it closed with an error and gave me a pop out message saying I should turn off secure boot. After that, there was no GRUB and it boots straight to windows.

Here is the first boot repair link: paste.ubuntu.com/7517709

I then formatted the partitions again and did the whole thing again with secure boot disabled this time. Again no GRUB menu and boots straight to windows 8 (yes windows 8 on my laptop works with secure boot disabled), so I entered the live version and ran boot repair again. This time it did not tell me that I should disable secure boot, but it did not solve the problem either. Same problem, no GRUB and boots straight to windows.

Here is the first boot repair link: paste.ubuntu.com/7536732

A couple of more points:

· I cannot change the OS boot manager in BIOS, i.e. I cannot choose boot priority between windows 8 & ubuntu. Simply because that option does not exist

· Boot Manager in BIOS allows me to choose between CSM and UEFI only

Appreciate any help to make the dual boot work. Thanks

5
  • yes i read it and i did all my installation steps according to it and the articles stated inside it too. When grub appeared after the first installation it booted ubuntu but not windows. I did the boot repair as suggested and now, no grub menu and i cannot see ubuntu anywhere on my laptop.
    – Amro A.
    May 30, 2014 at 10:23
  • did you update grub? did you follow according to this help.ubuntu.com/community/…
    – JoKeR
    May 30, 2014 at 10:35
  • i did the normal recommended repair and i did not mess around with the advanced option. The warning that is there kind of made me think twice. Even though i am itching to unticking the Secure boot option in the advanced options. I was also thinking of changing the OS to boot by default from "sda9(Ubuntu 14.04 LTS)" to "Windows (via sda9 menu)". Do not know if that is a good idea though. Would you recommend any of those settings?
    – Amro A.
    May 30, 2014 at 12:04
  • to fix grub it's recommended to follow the instruction that provided in a link of my previous comment.
    – JoKeR
    May 30, 2014 at 12:16
  • i did and nothing worked, same old problem, plus the recommended settings are for MBR and i have a gpt HDD.
    – Amro A.
    Jun 1, 2014 at 12:18

1 Answer 1

0

You need boot with USB-Live and open terminal.

Then tipe:

$ sudo -i

find out your linux disk :

fdisk -l

Mount it:

mount /dev/sdaX /mnt (where X is the partition where you need mount boot)

Recover:

grub-install --root-directory=/mnt /dev/sda

And then reboot.Good luck!

3
  • this is what i got when i ran fdisk -l WARNING: GPT (GUID Partition Table) detected on '/dev/sda'! The util fdisk doesn't support GPT. Use GNU Parted. Disk /dev/sda: 1000.2 GB, 1000204886016 bytes 255 heads, 63 sectors/track, 121601 cylinders, total 1953525168 sectors Units = sectors of 1 * 512 = 512 bytes Sector size (logical/physical): 512 bytes / 4096 bytes I/O size (minimum/optimal): 4096 bytes / 4096 bytes Disk identifier: 0x0ded6bd9
    – Amro A.
    May 30, 2014 at 11:34
  • and this too Device Boot Start End Blocks Id System /dev/sda1 1 1953525167 976762583+ ee GPT Partition 1 does not start on physical sector boundary. I had to do it in 2 comments coz its a bit long. I guess paragraphs are not allowed in the comments coz everything is a block even though i wrote them in paragraphs
    – Amro A.
    May 30, 2014 at 11:38
  • after using Gparted i found that the partition is sda9, so i ran the mount command and i got this message 'mount: can't find /dev/sda9/mnt in /etc/fstab or /etc/mtab'
    – Amro A.
    May 30, 2014 at 11:58

Not the answer you're looking for? Browse other questions tagged .