1

I've just bought a cheap usb wifi adapter from ebay. It is mediatek based, lsusb outputs:

Bus 001 Device 003: ID 148f:7601 Ralink Technology, Corp. 

I'm on 3.13 kernel, and the driver provided in the cd shipped with the adapter didn't wanted to compile. I've followed this guide and then everything compiled fine.

The problem is, when I plug in the adapter it connects fine but, after a couple of seconds, the kernel panics. Can anyone help me find out what's wrong? Here's a picture of the screen when the PC crashes:

enter image description here

3

I have a device with the same device ID 148f:7601, and I suffered the same problem. I'm not an expert, but I've found out that Victor Martinez solved the problem. (I'm writting this post right after my computer connects to a wifi network!)

You can download the modified driver from here. After downloading it, follow the below instructions to compile and install:

$ cd Downloads
$ tar -xzf \~victored-+junk-mt7601U-linux-driver-64bit-r2.tgz
$ cd \~victored/+junk/mt7601U-linux-driver-64bit/
$ sudo make
$ sudo make install
$ sudo modprobe mt7601Usta

I've tried it on Ubuntu 14.04 64bit, with version 3.13.0-24-generic kernel (a kernel in the Ubuntu install DVD) I think 64bit kernel can get the kernel panic problem.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.