1

I would like dropbox to autostart at startup. I installed dropbox and in dropbox preferences I set "autostart dropbox at startup".

At startup I see from system monitor that the process dropbox is running, the command line associated to this process is ~/.dropbox-dist/dropboxd but the dropbox daemon is not running, my files does not sync and the dropbox tray icon does not appear.

To start dropbox I have to kill this process from system monitor and start dropbox through the dash (doing this I have that the dropbox tray icon appears and dropbox works).

I have already tried:

$sudo apt-get remove --purge nautilus dropbox
$sudo apt-get autoremove

and reinstall dropbox but it did not solve the problem.

  • 1
    I have this problem in one of the computer at work. 12.04, the user related it to an update. I have "solved" it by adding a new command to the startup: 'sleep 40;dropbox stop;sleep 10;dropbox start'. But I'd like to find the cause and a proper fix. – Javier Rivera May 30 '14 at 7:21
0

Go to your startup applications by typing startup applications in dash.

In the list of applications. choose dropbox and select edit among the buttons on the right.

Change the 'Command' part to dropbox start -i and save.

See image below:

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.