0

I need to format a drive with Ext2 or Ext3 file system and copy a film DCP on it. I've used GParted to format the drive but cannot copy the DCP into the drive as it says I do not have the permission. I'm using Ubuntu 14.04 with a live DVD to boot. Disks gives me the option to format only on Ext4 which is no good for me. I did try to format with Ext4 and I can copy just fine but the drive has to be Ext2 or 3. I'm very new to Ubuntu, please help! Thanks!

1

ext4 is new but also holds compatibility with other programs that are old and restrict themselves to ext2/3 a lot of times (depending on the application). Either way, formatting with any of these three should not give this error.

You need to go into console and mount it to a folder your user has full access to like this (and we're going to assume your partition is /dev/sdc1 and this is going to start from the beginning - aka GParted never happened here)

user@host:~$ mkdir mntDCP
user@host:~$ sudo mkfs -t ext3 /dev/sdc1
user@host:~$ sudo mount /dev/sdc1 mntDCP/
user@host:~$ sudo chown user:user -R mntDCP/

If this doesn't work let me know so we can try other options.

Also if you could explain why Ext4 is such blasphemy it may help find the solution quicker as well.

  • Thanks so much! I' will try it now. The film festival I'm sending the DCP to specified Ext2 or 3 as some of their servers are pretty old. I just don't understand why it locks the newly formatted drive and can't do a simple action as Copy/paste. – user286378 May 29 '14 at 7:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.