I can't boot from any Ubuntu boot device. I downloaded ubuntu-14.04-desktop-amd386.iso and I did the following:

  1. Burned .iso to a flash drive using Universal USB Installer (that was recommended from www.ubuntu.com)
  2. Tried to use other programs like UNetbootin and UltraISO
  3. Used another flash drive
  4. Used other laptops and PCs
  5. Flash boot with Windows OSs
  6. I also tried with DVD .iso burn

Your advice please.

  • What do you mean exactly on #5? Are you able to set your BIOS to boot from a USB drive? Is the boot order USB first? Did you include the .iso file along with the files required to boot the .iso (With UNetBootin, you need to also put the .iso on the disk as well as the files required to load it on boot) – No Time Jun 18 '14 at 4:18
  • Yes, I'm able to do all things mentioned by you, but also I can't boot, the same bootable flash works on another UEFI PCs. – user281814 Jun 20 '14 at 7:07
  • The ISO name ubuntu-14.04-desktop-amd386.iso seems odd. It should be either i386 or amd64 in your case. Where did you download it? Did you verify its integrity? – David Foerster May 8 '15 at 12:37

Recent changes to Ubuntu (13.04 and beyond) and Windows (8 for sure and beyond) start using GPT partition tables and UEFI booting by default to piss people off that haven't experienced them before.

You are likely running into a legacy vs. UEFI boot problem or your HDD boot order hasn't been arranged after you plugged in the boot disk.

Plug in the USB or DVD before getting to the BIOS, go to the boot settings and move it to the top of the boot order.

If it's the former issue:

Go into your BIOS and select whichever mode (legacy or UEFI) is not currently active to troubleshoot. It may even be a combination of both of these solutions above.

This will not work with an installation of Windows 8 already on the PC using UEFI/Secure boot unless you use legacy mode and dual-boot in an annoyingly complicated way using EasyBCD

I have run into this issue many times and have completely given up on EFI booting since it makes no difference to me how fast the PC loads. That just makes getting to the BIOS 102031x harder.

Besides, who uses Windows anymore anyway? Right? ;) time to go *nix only son. Join the cool kids.

This may not work for sure in your situation but hopefully it helps.

Let me know if there's more I can do.

  • I think my problem is with the bios, I can't find boot mode to change it to UEFI, My Laptop is Toshiba Sattelite C850-B798, bios version 6.20 type InsydeH20, My current OS is windows 7 x64. What I should do now? – user281814 May 29 '14 at 10:34
  • Did you happen to check the md5sum of the ISO file you downloaded against what the server has listed? – Deryck May 30 '14 at 0:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.