2

My Fn+F8 and Fn+F9 keys to change the screen's brightness appear to no longer work on my Thinkpad laptop.

# ls /sys/class/backlight/
thinkpad_screen

Some guide told me to make this:

# cat /usr/share/X11/xorg.conf.d/20-intel.conf 
Section "Device"
        Identifier  "card0"
        Driver      "intel"
        Option      "Backlight"  "intel_backlight"
        BusID       "PCI:0:2:0"
EndSection

And someone else said to do this:

# cat /usr/share/X11/xorg.conf.d/20-nvidia.conf 
Section "Device"
        Identifier "NVIDIA"
        Driver "nvidia"
        Option "NoLogo" "True"
        Option "RegistryDwords" "EnableBrightnessControl=1"
EndSection

This is my GRUB CMDLINE_LINUX_DEFAULT line, in case it's relevant: GRUB_CMDLINE_LINUX_DEFAULT="nosplash nomodeset acpi_osi=Linux acpi_backlight=vendor"

The Ubuntu wiki page on backlight issues says

Add just kernel parameters thinkpad-acpi.brightness_enable=1 acpi_backlight=vendor to /boot/grub/menu.lst . Execute: sudo update grub

but I don't have a menu.lst and I suspect this is outdated.

Doing something like this does not work: echo 10 > /sys/class/backlight/thinkpad_screen/brightness

Any ideas?

  • Start by looking into /sys/class/backlight and see which folders are present. Then try echo 300 | sudo tee /sys/class/backlight/intel_backlight/brightness > /dev/null changing intel_backlight to yours. Experiment with the 300 figure. If this works then we can post a more reasonable solution. – To Do May 28 '14 at 21:05
  • 1
    Also, can you change the brightness from the Brightness and Lock settings? – To Do May 28 '14 at 21:06
  • Hi! Notice that the first thing I posted was a listing of the folders in /sys/class/backlight and the last thing in my original post was showing that echoing numbers into /sys/class/backlight/thinkpad_screen/brightness does not work. I do not have Brightness and Lock settings (or at least I don't know how to get to them) as I run xmonad and do everything through a shell. – Espressofa May 28 '14 at 21:09
  • Why did you add acpi_backlight=vendor? I think it can be the problem. – Alen May 28 '14 at 21:09
  • I had to do that in 13.10 for the backlight. Should I try removing? What should my GRUB_CMDLINE_LINUX_DEFAULT line be? Do I need acpi_osi=Linux? I have no idea what nomodeset is but someone had me add it for something.... – Espressofa May 28 '14 at 21:10
1

Removing all kernel boot parameters and installing the ppa:xorg-edgers/ppa's nvidia drivers fixed the issue.

0

I found that changing my GRUB CMDLINE_LINUX_DEFAULT line to the following works on my Lenovo y510p:

GRUB_CMDLINE_LINUX_DEFAULT="nosplash quiet acpi_backlight=intel_backlight"

To accomplish this, run this command:

sudo gedit /etc/default/grub

Make the edit, save / exit gedit. Then run the command:

sudo update-grub

Now all you need to do is restart by typing the following command and back lights should work.

sudo reboot

Now the "Fn + up arrow" or "Fn + down arrow" works to brighten or dim the display

0

Creating this file solved the problem for nvidia nvs5400m in a Thinkpad T530. Thank you.

cat /usr/share/X11/xorg.conf.d/20-nvidia.conf 


Section "Device"
        Identifier "NVIDIA"
        Driver "nvidia"
        Option "NoLogo" "True"
        Option "RegistryDwords" "EnableBrightnessControl=1"
EndSection

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.