2

Has anyone had any luck installing wmic (wmi client) under Ubuntu Server 14.04 LTS?

I tried following the document http://techedemic.com/2012/11/05/installing-wmic-in-ubuntu-12-04-lts-64-bit-desktop/ however I still can't get a successful make.

Has anyone had any luck getting a compiled version of wmic onto Ubuntu, I need this for nagios check_wmi_plus, but it always errors, details below.

I'm not sure if the support information is telling me to install those modules or not (sorry if being dumb, new to Ubuntu from OpenSuse).

Many thanks in advance.

Summary:

Support for GTK+ frontends: no (install gtk,gconf)
Support for SSL in SWAT and LDAP: no (install GNUTLS)
Support for threads in smbd (see --with-pthread): no (install PTHREAD)
Support for intelligent command line editing: no (install READLINE)
Support for changing process titles (see --with-setproctitle): no (install SETPROCTITLE)
Support for using extended attributes: yes
Support for using libblkid: no (install BLKID)
Support for using iconv: yes
Support for using pam: no (install PAM)
Using external popt: no
Developer mode: no
Automatic dependencies: no (install GNU make >= 3.81 and see --enable-automatic-dependencies)
Building shared libraries: yes
Using shared libraries internally: no (specify --enable-dso)

make[1]: Entering directory `/tmp/wmi-1.3.14/Samba/source'
Creating lib/util/util_proto.h
Creating lib/charset/charset_proto.h
Creating param/proto.h
Creating libcli/util/proto.h
defined(@array) is deprecated at ./pidl/pidl line 583.
        (Maybe you should just omit the defined()?)
Compiling ./librpc/idl/atsvc.idl
/usr/include/stdc-predef.h:0: Syntax error near '3'
Failed to parse ./librpc/idl/atsvc.idl at ./pidl/pidl line 583.
make[1]: *** [idl] Error 1
make[1]: Leaving directory `/tmp/wmi-1.3.14/Samba/source'
cd Samba/source ; \
        cp bin/winexe ../../bin ; \
        cp bin/wmic ../../bin ; \
        cp bin/shared/*async_wmi_lib.so.0* ../../lib/python
cp: cannot stat ‘bin/winexe’: No such file or directory
cp: cannot stat ‘bin/wmic’: No such file or directory
cp: cannot stat ‘bin/shared/*async_wmi_lib.so.0*’: No such file or directory
make: *** [pywmi-installed] Error 1
  • I'm dealing with the exact same issue now. I have tried wmi-1.3.13, wmi-1.3.14 (with 3 patches), and wmi-1.3.16, but to no avail. I am reconsidering nagios/shinken as a result, but I would love to see an answer to this one! – πόδας ὠκύς Jun 2 '14 at 2:39
3

Try adding compiler option -ffreestanding. It worked for me with Ubuntu 14.04 LTS.

make "CPP=gcc -E -ffreestanding"

I found this solution in a comment here: Installing wmic in Ubuntu 12.04 (LTS) 64-Bit Desktop

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.