2

Ubuntu 14.04 x64
Chrome 35.0.1916.114
Using NVIDIA binary driver 331.38 (also tried X.Org X Server Nouveau)
Two monitors

Both in Unity and Gnome Chrome displays grey rectangles, on scroll it sometimes leaves some rectangular areas non-updated or doesn't remove old rectangles, but writes new text as if it was a new layer above the old texts. Firefox and Chromium didn't show this bug.

The screenshot: buggy chrome rendering

Tried:
changing hardware acceleration in chrome, using the Nvidia or x.org drivers - in all possible four combinations, including a cold reboot between the settings changes.

Ideas checked:
Turned off all extensions in Chrome. After this chrome started crashing upon startup.
Uninstalled google-chrome-stable using dpkg, deleted ~/.cache/google-chrome and ~/.config/google-chrome (only backed up SessionBuddy database)
Added google's repo to the repo list, installed from it.
With a fresh install still, there are render bugs.
So I enabled SessionBuddy and FlashControl extensions since there's no evidence they affect this behaviour.
Checked if there's ulimit - it says 'unlimited'.

The probability of rendering bugs increases with the number of tabs. Some tabs go completely grey and I can only refresh them or close.

Also, I've found chrome flags setting with lots of flags for render/gpu/hardware acceleration. Didn't try playing with them yet.

Probably there's some GPU memory limit per app/process? Or, maybe, other options?

UPD: The bug disappeared next day but emerged again today. Seems like the bug arises when I have more than 13 windows with more than 100 tabs total. Seems like it hits some memory/gpumem limits and the problem comes in play. When I close some tabs and join some windows the bug disappears after the F5 refresh. I closed and merged windows to 79 tabs and 7 windows total and the bug disappeared. Any ideas?

  • Hmmm I'm having the same problem. It's really not clear what's causing it, though. – skeggse Jun 3 '14 at 0:30
  • 1
    @distilledchaos check the answer, people on google products forum have found the reason of the bug and the way to fix it. – Ilya Sheershoff Jun 7 '14 at 9:44
2

Seems like it's ulimit -n that prevents Chrome from creating new shmem files.

Temporary fix

(all the commands should be run within one terminal)

ulimit -Sn 4096
ulimit -Hn 4096
google-chrome

Permanent fix

(requires reboot)

Step one:

sudo -H gedit /etc/security/limits.conf

add the lines (or check what lines to edit)

* soft nofile 8192
* hard nofile 65536
root soft nofile 8192
root hard nofile 65536

(seems like wildcard has no effect on root user, so the root user should be noted explicitly if needed)

Step two:

sudo -H gedit /etc/pam.d/common-session

add the line

session required pam_limits.so

Step three:

Reboot the machine

0

Looks like this is a bug. See https://code.google.com/p/chromium/issues/detail?id=136054

Disabling GPU support seems to fix it for now:

google-chrome --disable-gpu

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.