1

In Ubuntu tweak 0.8.7 which is installed in my Ubuntu 14.04 LTS running unity I could not delete a particular file called 'fail' in the thumbnail cache. I am actually trying to remove that file with the 'Janitor' feature that is available with Ubuntu tweak. Every time I try deleting that file Ubuntu tweak crashes(i.e. closes). Why does this happen and how to delete it? By the way I could delete every other thumbnail cache file and also other kind of cache except this 'fail' file. Below is a screen shot:-

enter image description here

  • 1
    What happens when you run Ubuntu Tweak in terminal? – Wilf May 28 '14 at 11:56
  • Do you have a file/folder named fail in your ~/.cache/thumbnails/ folder? If yes, paste the output of ls -l ~/.cache/thumbnails/ – jobin May 28 '14 at 11:57
  • @Wilf Same issue persists if i run ubuntu-tweak in terminal – VenkiPhy6 May 28 '14 at 12:03
  • @Jobin pastebin.ubuntu.com/7536157 – VenkiPhy6 May 28 '14 at 12:05
  • @Venki - I was thinking about whether there would be any error outputs in the terminal from when it tried to delete the cache. – Wilf May 28 '14 at 12:05
4

The ~/.cache/thumbnails/fail directory has somehow been owned by root when you(your user) should have been the owner. Ubuntu tweak crashed because it was trying to delete a file/folder which it is not permitted to and this has probably not been handled in it(might be bug, consider filing if not already filed against ubuntu-tweak).

First change the ownership of the folder by opening a terminal using Alt+F2 and typing "terminal" and then in the opened application, type the following:

sudo chown $USER:$USER ~/.cache/thumbnails/fail -R

and then reopen ubuntu tweak and try to clear the cache again.

Here the first $USER represents you as a user(is an environment variable set on boot and represents the user logged in) and the second one represents your group(the name of your group is same as your username, so can reuse the variable).

Refer to man chown for more.

  • Why $USER twice? – VenkiPhy6 May 28 '14 at 12:12
  • @Venki: Have edited my answer, please have a look. – jobin May 28 '14 at 12:14
  • Why Alt+F2 when you can always use Ctrl+Alt+t ? :-) – VenkiPhy6 May 28 '14 at 12:16
  • @Venki: Some versions of ubuntu(older versions as well as some distros like xubuntu) don't have that shortcut. – jobin May 28 '14 at 12:17
  • 1
    ok ... This answer is very precise then! Great work! – VenkiPhy6 May 28 '14 at 12:21
-4

Or simply do

gksudo ubuntu-tweak
  • 3
    -1 That kind practice leads to user cache entries owned by root, which is the cause of OP's issue in the first place. Using sudo on graphical applications is discouraged under all circumstances; use gksudo and friends instead. – David Foerster Apr 11 '15 at 14:37
  • 2
    Running ubuntu-tweak as root (sudo) can cause several problems and at best would affect root rather then the current user. It can cause the OP problem and other problems including a failure to be able to log in graphically. – Panther Apr 11 '15 at 15:37

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.