1

I'm getting this error when I execute my db_server

**root@v-8966:/home/talisman/db# ./db_server

./db_server: error while loading shared libraries: libmysqlclient.so.15: cannot open shared object file: No such file or directory

Can anyone help me?

2

libmysqlclient.so.15 is no longer available in any supported version of Ubuntu. Ask your program's developers if a more recent version, linked against a more recent version of libmysqlclient, exists. If not, you might be out of luck.

2
  • I'm trying this on a vps and in my virtual machine this works – Zedja May 28 '14 at 9:54
  • It probably installs an alias of some sort then... You probably have some version of libmysqlclient installed on your virtual machine, just install that same version on your VPS. – fkraiem May 28 '14 at 9:55
-1

You didn't install the MySQL client for PHP. Try installing it

sudo apt-get install php5-mysql

I am assuming that you are using the default PHP 5 that comes with Ubuntu.

3
  • It says its already installed in the newest version – Zedja May 28 '14 at 9:54
  • Do you have more than 1 php installed? Can you check that out? – Shing Kae May 28 '14 at 15:17
  • Oh, my bad, after reading fkraiem's answer found out is not about PHP mysql client library. You should check the version of your OSes on your virtual machine and on the vps. The differences will give you some idea. – Shing Kae May 28 '14 at 15:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.