48

I am running Ubuntu 14.04 LTS 32 bit. I have installed HandBrake rev5474 (i686), which I believe is the latest, and the Ubuntu Restricted Extras. I am able to play DVDs via VLC but when it comes to ripping them, so that I can back them up to my Twonky media server, I have issues.

I launch HandBrake and find that the only format available for me to select is MKV.

When I used to run Handbrake on this machine while I was running Ubuntu 13.10 and lower I had no issues and **lots of formats (including MP4 which is what I'm really after) but since reformating and installing 14.04 I've had this issue.

Any help would be much appreciated.

1 Answer 1

68

This is Debian bug #695225 - No support for mp4 container in Handbrake. There is a PPA with a fixed version of Handbrake, see Handbrake Releases PPA. To enable it do:

sudo apt-get purge handbrake # remove any old versions
sudo add-apt-repository ppa:stebbins/handbrake-releases
sudo apt-get update
sudo apt-get install handbrake-gtk

To get the mp4 format to work you must go into preferences and disable the "ipod friendly mkv format" checkbox.

handbrake-gtk also available in apps.ubuntu

12
  • Partially successful. With the necessary "sudo" I followed the code above but still only had MPV.
    – Mitty
    May 28, 2014 at 19:57
  • 4
    I needed to add the repo, as given by bain, but needed to install "handbrake-gtk" instead of "handbrake".
    – Joachim
    Jun 6, 2014 at 16:31
  • 1
    handbrake-gtk also available in apps.ubuntu
    – user47206
    Oct 17, 2014 at 10:53
  • 1
    Using this answer I am only able to convert to mkv or m4v. Not mp4. Jul 25, 2015 at 14:15
  • 6
    @JonathanRogiest Disable Preferences -> "Use iPod/iTunes friendly .m4v file extension for MP4"
    – jmiserez
    Aug 8, 2015 at 19:45

Not the answer you're looking for? Browse other questions tagged or ask your own question.