1

About 1/3 of the time that I boot my laptop, I get an error message that says

Error: Malformed file.
Press any key to continue...

I press a key, and then my computer boots up and I can't discern any negative effects.

It's kind of disconcerting, and does delay the boot process.

How do I resolve this error and ensure my system is stable?

  • Is that the only error message you get? If yes, any clues in /var/log/syslog or in /var/log/boot.log? – jobin May 28 '14 at 4:32
  • @Jobin, that's the only text on screen. I didn't see anything in either log that seemed related. However, /var/log/syslog is huge, so maybe I missed it. Is there a command I can run that would help refine a search for anything helpful? – Questioner May 28 '14 at 5:24
3

It is a bug in Grub, see Launchpad bug #1311247 - error: malformed file, press any key to continue. The upstream bug report is at bug #42134: loadenv.c – check_blocklists – algorithm for block overlap check is wrong. There does not seem to be a reliable workaround - you will just have to wait for it to be fixed.

| improve this answer | |
1

A lot of users have this problem, including myself.

Found a piece of text that solved the issue for me and hopefully others as well.

edit /etc/default/grub and add:

# If you want to enable the save default function, uncomment the following
# line, and set GRUB_DEFAULT to saved.
GRUB_SAVEDEFAULT=true

After saving the file update grub:

sudo update-grub

Re-start the computer and the issue might be gone :-)

Recently I found out that ACPI settings in the BIOS may also cause "malformed file" message during boot. My computer does not shut down completely and therefore I was messing around with the ACPI settings. It is interesting to see that this warning has multiple root causes

| improve this answer | |
0

I'm currently running Linux Mint 17 with 3.14.5-031405-lowlatency kernel. I installed this kernel to fix slow wireless issues.

I started noticing this same issue just a few days ago. I hit any key and it boots up fine.

The fix for me was to completely remove all of the old kernels (stock that came with Mint 17). I then performed a dist-upgrade, rebooted and am not getting the message any more.

I am not a linux guru so can't explain why this worked, just went on a hunch.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.