I recently installed Lubuntu 14.04 on my parents' old laptop, and I've been having a super difficult time getting the Broadcom card up and running. I've been following this thread: Installing Broadcom Wireless Drivers

...but I'm still stuck.

lspci -vnn | grep Network showed:

06:05.0 Network controller [0280]: Broadcom Corporation BCM4306 802.11b/g Wireless LAN Controller [14e4:4320] (rev 02)

iwconfig showed:

lo        no wireless extensions.

eth0      no wireless extensions.

I've installed b43-firmware-installer and b43-fwcutter and also the linux-firmware-nonfree package. At boot, I keep getting a b43-phy0 error, so I tried sudo rmmod b43, and I got:

rmmod: ERROR: Module b43 is not currently loaded

I also tried:

    dmesg | grep b43
    [   17.318405] b43legacy-phy0: Broadcom 4306 WLAN found (core revision 4)
    [   17.384870] b43legacy-phy0: Loading firmware b43legacy/ucode4.fw
    [   18.046777] b43legacy ssb0:0: Direct firmware load failed with error -2
    [   18.046785] b43legacy ssb0:0: Falling back to user helper
    [   18.047858] b43legacy-phy0 ERROR: Firmware file "b43legacy/ucode4.fw" not
    found or load failed.
    [   18.047965] b43legacy-phy0 ERROR: You must go to
    http://wireless.kernel.org/en/users/Drivers/b43#devicefirmware and download the
    correct firmware (version 3).

I went to url it told me to, but it didn't tell me to do anything I haven't already tried.

Any help and/or suggestions would be greatly appreciated!

  • @ubfan1 Thanks a lot! That fixed it. We can consider this thread closed, I guess. May 29, 2014 at 6:31

1 Answer 1


Your 4306 hardware, according to http://wireless.kernel.org/en/users/Drivers/b43 takes the b43legacy driver, NOT the b43 driver. Try the firmware-b43legacy-installer package to see if that gets you the correct firmware (ucode4.fw) and puts it into /lib/firmware/b43legacy. It looks like you are pulling in the correct driver, it just doesn't have the correct firmware.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.