I ran a software update (Ubuntu 14.04) on my laptop over the weekend, which included an update from kernel 3.13.0-24 to 3.13.0-27, among other things. Today i had to take my laptop to work, so closed the lid and put it in my bag. However, it never went into suspend mode! I tried several times, even rebooting. Finally I tried the previous kernel from the grub menu (reverting back to the -24 one) and suspend works the same as it always had before.

Did something suspend related change between the -24 and -27 kernels used in Ubuntu 14.04? I think by only reverting to a previous kernel to temporarily fix it, i've ruled out any other software changes made during the weekend's upgrade.

EDIT: I've compared my syslog after an unsuccessful suspend with the results with the working kernel, and here's where they differ:

After these lines which appear in both logs,

May 28 13:44:20 inanna kernel: [  559.606085] nouveau  [     DRM] suspending client object trees...
May 28 13:44:20 inanna kernel: [  559.607177] nouveau  [     DRM] suspending kernel object tree...

the non-working suspend continues with

May 28 13:44:20 inanna kernel: [  561.606427] nouveau E[   PDISP][0000:01:00.0][0xc000857c][ffff880035a4af80] fini timeout, 0xc2061008
May 28 13:44:20 inanna kernel: [  561.606429] nouveau E[   PDISP][0000:01:00.0][0xc000857c][ffff880035a4af80] failed suspend, -16
May 28 13:44:20 inanna kernel: [  561.606430] nouveau E[     DRM] 0xd1500000:0xd15c7c00 suspend failed with -16
May 28 13:44:20 inanna kernel: [  561.606447] nouveau E[     DRM] 0xdddddddd:0xd1500000 suspend failed with -16
May 28 13:44:20 inanna kernel: [  561.606535] nouveau E[     DRM] 0xffffffff:0xdddddddd suspend failed with -16
May 28 13:44:20 inanna kernel: [  561.607173] nouveau E[     DRM] 0xffffffff:0xffffffff suspend failed with -16
May 28 13:44:20 inanna kernel: [  561.607273] nouveau  [     DRM] resuming display...
May 28 13:44:20 inanna kernel: [  561.607294] nouveau E[     DRM] bo ffff880092b8bc00 pinned elsewhere: 0x00000002 vs 0x00000004
May 28 13:44:20 inanna kernel: [  561.607295] [drm:drm_helper_resume_force_mode] *ERROR* failed to set mode on crtc ffff88024e006000
May 28 13:44:20 inanna kernel: [  561.607324] pci_pm_suspend(): nouveau_pmops_suspend+0x0/0xb0 [nouveau] returns -16
May 28 13:44:20 inanna kernel: [  561.607327] dpm_run_callback(): pci_pm_suspend+0x0/0x150 returns -16
May 28 13:44:20 inanna kernel: [  561.607329] PM: Device 0000:01:00.0 failed to suspend async: error -16
May 28 13:44:20 inanna kernel: [  561.607485] PM: Some devices failed to suspend, or early wake event detected
  • 1
    It's a kernel bug. Report it to Ubuntu. (I wonder if it has anything to do with "drm/nouveau: don't suspend/resume display on runtime s/r"?) As a workaround, you could try updating to one of the latest mainline kernels to see if it's fixed. Or just keep using your working kernel if it is otherwise fine.
    – bain
    May 28, 2014 at 23:02
  • Not sure if this will help you or not, I had a similar situation, every kernel update caused suspend to break. I have to uninstall and reinstall the FGLRX/Catalyst graphics driver and all works fine again, till the next kernel update, where I have to do it all again
    – dginsd
    Mar 7, 2015 at 5:55

1 Answer 1


I'm afraid we/you have very few options at the moment. We/You most probably suffer from Bug 1324697.

One of the workarounds is to use the kernel 3.13.0-24, as you already stated. The other is to use one of the mainline kernels of the kernel ppa. I chose the 3.16.0-031600 version.

  • 1
    Well, i was able to work around it, as i mentioned at the bottom of that bug report. It involves blacklisting the nouveau module in /etc/modprobe.d/ and ALSO then rebuilding the initrd to make sure that change stays in effect while booting, because otherwise you still can't unload the module. This is probably not an option if you only have an Nvidia graphics card... my laptop appears to have an additional Intel one. Or you could switch to the non-free official Nvidia driver, i haven't tried that. Aug 5, 2014 at 21:17
  • But blacklisting the nouveau driver means you only run on the intel side (I suppose you have an optimus card too), and are not able to use the nouveau driver entirely.
    – nerdoc
    Aug 6, 2014 at 15:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .