4

I imported my Google calendar into Evolution and now I can't find a way to delete the calendar. How can I delete it?

3

If you have imported it the right way (New Calendar => Type Google), you can remove it right-clicking on the calendar name and then deleting it.
If you have imported a CVS/ICS calendar file (Google calendar => Export), this approach doesn't work.

alt text

  • 1
    Some calendars can't be just be removed using the UI (as added by online accounts), the only way I've found is to manually remove the matching sources from ~/.config/evolution/sources/. You can easily grep the ones you want remove by checking the DisplayName on them (they're in plain text). – Treviño Jun 9 '15 at 20:22
2

I was having a similar issue, and found that I could delete calendars if I shut down the clock applet first:

1) Go to System>Administration>System Monitor

2) Click on "clock-applet" then "End Process"

Don't restart when prompted to do so. You should now be able to delete your calendars.

To get the clock applet back, you may have to add it back to your panel by right-clicking on it, selecting"Add to panel", then "Clock", and placing it where you want.

1

In my case, the calendars was shown because I added my Google accounts from the GNOME settings.

screenshot

When added the accounts, I selected to use them also for the calendars, thinking I could then delete the calendars I didn't need. I then discovered I could not delete the calendars I didn't need from Evolution.

What I did was opening the GNOME settings again, click on the accounts listed there, and deselect Calendar from them.

screenshot

I didn't need to remove the accounts and re-add them. Once I deselected Calendar from my Google accounts, I just closed Evolution and re-opened it to not see the Google calendars on Evolution.

  • I'm on LinuxMint 19.1 Cinnamon and this was my problem. This applies to Cinnamon as well as GNOME. – Pockets Jul 18 at 0:30
0

I had the same problem: I could not remove the Google calendar, nor the contacts.

My solution was to:

  1. Remove the Gmail account (so calendar and contacts were also removed)
  2. Add the Gmail account again, choosing not to add calendar and contacts

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.