6

I am using Ubuntu 12.04 64bit LTS and am trying to use a Logitech G27 Steering Wheel and Pedals. Everything but the steering feedback is working fine.

I can test the feedback with fftest:
(note the line "Axes query" is empty)

$ fftest /dev/input/event11 
Force feedback test program.
HOLD FIRMLY YOUR WHEEL OR JOYSTICK TO PREVENT DAMAGES

Device /dev/input/event11 opened
Axes query: 
Effects: Constant 
Number of simultaneous effects: 16
Upload effects[0]: Invalid argument
Upload effects[2]: Invalid argument
Upload effects[3]: Invalid argument
Upload effects[4]: Invalid argument
Upload effects[5]: Invalid argument
Enter effect number, -1 to exit
1
Now Playing: Constant Force

but the feedback is very weak and it does not work with ffcfstress or my target application.

$ ffcfstress -d /dev/input/event11 -o
ERROR: device (or driver) has no force feedback support [ffcfstress.c:166]
$

I hope you can help me with this problem. Thanks.

Update

I tried with Ubuntu 14.04 and I can use ffcfstress to use force feedback. Unfortunately we'd like to stay with Ubuntu 12.04 since all this is running on a cluster machine with many people working on it. It also works on OSX with SuperTuxKart (I know, a professional way to try it out.)

5
+150

Unfortunately it is not available directly as a binary, but you can easily compile it using the following commands:

Get some dependencies:

sudo apt-get install libusb-1.0-0-dev git jstest-gtk joystick

Download the source:

git clone https://github.com/thk/LTWheelConf.git

Build the source:

cd LTWheelConf
make

You should now have an executable named ltwheelconf.

Install

sudo cp ltwheelconf /usr/local/bin/


Use LTWheelConf

List all found/supported devices

sudo ltwheelconf --list

Supported wheel shortname values: 'DF' (Driving Force)
'MR' (Momo Racing)
'MF' (Momo Force)
'DFP' (Driving Force Pro)
'DFGT' (Driving Force GT)
'G25' (G25)
'G27' (G27) Set wheel to native mode

sudo ltwheelconf --wheel <your-wheel-shortname> --nativemode

Set wheel rotation range of 900 degrees

sudo ltwheelconf --wheel <your-wheel-shortname> --range 900

Examples:
Put wheel into native mode:

sudo ltwheelconf --wheel G25 --nativemode

Set wheel rotation range to 540 degree:

sudo ltwheelconf --wheel G27 --range 540

Set moderate autocenter:

sudo ltwheelconf --wheel DFP --autocenter 100 --rampspeed 1

Disable autocenter completely:

sudo ltwheelconf --wheel G25 --autocenter 0 --rampspeed 0

Set native mode, disable autocenter and set wheel rotation range of 900 degrees in one call:

sudo ltwheelconf --wheel DFGT --nativemode --range 900 --autocenter 0 --rampspeed 0


Automagically invokes LTWheelConf
We can add a rule to UDEV to automatically invoke LTWheelConf when the steering wheel is connected.
This can be done using the following command (use the correct shortname instead of !):

echo 'ATTRS{idVendor}=="046d", ATTRS{idProduct}=="c294", RUN+="/usr/local/bin/ltwheelconf --wheel <your-wheel-shortname> --nativemode --range 900"' | sudo tee -a /etc/udev/rules.d/90-logitech-wheel.rules

Now you need to restart UDEV:

sudo service udev restart


Extra information from Elder Geek what can be found here.

  • Unfortunately, it did not help. It detects the wheel and tells me that the wheel is already in native mode. It also recognizes all Axis (like before), but it does not give stronger feedback with fftest. Everything is like before. Also, in Applications there is still no feedback (at least not hard enough that you can feel it). Is there another option that can help with force feedback that I missed? – verpfeilt Jun 2 '14 at 19:31
  • 1
    I believe there is a gain function in LTWheelConf..... source:lfsforum.net/showthread.php?t=74115 post by MikeB – Elder Geek Jun 4 '14 at 15:32
  • @ElderGeek added your link. – Korkel Jun 4 '14 at 17:50
  • I tried, but it does not work. It works with Ubuntu 14.04 and OSX (just plugged it in and use ffcfstress). Unfortunately (as I added in the question) it would be necessary to convince a lot of people to upgrade the machine to 14.04. We'd like to avoid this. Maybe there is some driver/module thing we could upgrade? There must be a reason why it works on 14.04. – verpfeilt Jun 5 '14 at 10:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.