2

I installed rEFInd to ESP on my Macbook Pro Retina running Mavericks (with FileVault on). Here is my partition info:

/dev/disk0
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *500.3 GB   disk0
   1:                        EFI EFI                     209.7 MB   disk0s1
   2:          Apple_CoreStorage                         199.5 GB   disk0s2
   3:                 Apple_Boot Recovery HD             650.0 MB   disk0s7
   4:                  Apple_HFS Work                    200.0 GB   disk0s5
   5: 0FC63DAF-8483-4772-8E79-3D69D8477DE4               99.7 GB    disk0s6
/dev/disk1
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                  Apple_HFS Mac                    *199.1 GB   disk1

disk0s6 is my Ubuntu partition.

With this setup, it boots from EFI properly, but only Ubuntu (14.04, upgraded) is shown as an option in the rEFInd boot screen. There is no trace of my OS X disk and the only way I can boot into it is by selecting the disk from an Option-boot screen.

How do I fix this so that both my OS X and Ubuntu are displayed?

  • See answer to Unable to boot OS X after installing Ubuntu – bain May 27 '14 at 21:08
  • Adding this menuentry worked for me! Thank you. I had to comment out the dont_scan_volumes entry completely from refined.conf (refined 0.8.3, Mac OS X with encrypted disk /vault/ + Win 7 partition) a minor thing, instead of icon EFI/refind/icons/os_mac.icns Use icon EFI/refind/icons/os_mac.png I guess it's because of a newer version of refined – user318405 Aug 19 '14 at 16:48
2

Try setting scan_delay 1 in the refind.conf file. (That file should be in the EFI/refind/ directory on your /dev/disk0s1//dev/sda1 partition.) Sometimes rEFInd doesn't scan some partitions in its default configuration. This seems to be the result of an EFI that's sluggish about registering its partitions, so they don't show up when rEFInd first starts. Adding a delay to the scan works around this problem.


EDIT: Sorry; I didn't notice that you're using encryption. Try uncommenting the dont_scan_volumes option in refind.conf and remove "Recovery HD" from the list.

  • I tried setting a delay (even much longer than 1) but it still does not display OS X. This is getting to be way too complicated for me to debug... None of the advice I've found seems to help :( – rm -rf Jun 4 '14 at 5:27
  • See my edited response, above. – Rod Smith Jun 4 '14 at 12:25
  • Sweet, thanks! I now see that this information is in your website under the docs for dont_scan_volumes... Perhaps it would be useful to also mention it under the ESP boot section, which is where I looked for info on using rEFInd with full disk encryption. – rm -rf Jun 4 '14 at 14:53
0

Try adding a custom menu entry for OS X in refind.conf:

menuentry "OS X" {
  icon EFI/refind/icons/os_mac.icns
  volume "Mac"
  loader /System/Library/CoreServices/boot.efi
  ostype MacOS
}
  • This adds a menu, but does not boot OS X. I suppose this is because the disk is encrypted and thus it cannot read /System/Library/CoreServices/boot.efi – rm -rf May 28 '14 at 1:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.