0

Apache is 2.4.7 in the new 14.04 release.

Various website and release notes mention that lua via mod_lua became available.

There is a lua.load file in /etc/apache2/mods-available, but the corresponding module, mod_lua.so is not present in /usr/lib/apache2/modules.

There is not libapache2-mod-lua to be found in apt.

My question is: how is mod_lua installed?

Thanks!

  • Package names: lua5.1 and liblua5.1.0-dev (numbers may vary ;) ) – Rinzwind May 27 '14 at 11:46
0

Simple answer: You can't! The Ubuntu package maintainer did not bother installing the requirements for building this module, and thus it is not included, even though it's a core module. You may file a bug with Ubuntu, or you can check out the Apache Helpdesk PPA at https://launchpad.net/~apache-helpdesk and fetch a version of httpd with mod_lua included.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.