4

I was trying to change the user agent in Gnome Web 3.12 but I can't find any good tutorial on how to do his. I want to set it to the Google Chrome's UA, so it isn't detected as "Safari on Linux", and some pages load like in Chrome (google.com for example).

Some sites say it's through dconf but there's no /apps/empathy key.

The branding.conf file says USER AGENT in the header but there's no UA string set.

Any help would be appreciated. Thanks.

1 Answer 1

5

It is possible using dconf, the key is org.gnome.Epiphany user-agent

The default is empty, so this is probably why you see no UA string set there.

You can also try gsettings set org.gnome.Epiphany user-agent "Mozilla/5.0 (Windows NT 6.3; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/37.0.2049.0 Safari/537.36" by command line, should do the trick.

Update December 2021

It would appear as if the user-agent option has been moved under the web folder and that would change the command to be gsettings set org.gnome.Epiphany.web:/org/gnome/epiphany/web/ user-agent "Mozilla/5.0 (Windows NT 6.3; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/37.0.2049.0 Safari/537.36".

2
  • another way is through gconf: /apps/epiphany/general/user_agent. Source:mail.gnome.org/archives/epiphany-list/2011-May/msg00010.html
    – Elder Geek
    Jun 26, 2014 at 17:56
  • Thanks :) I found out how to do it in dconf going to org > gnome > epiphany > user-agent. Did the same as that command through the GUI. Just forgot to answer the question and mark it as solved then. Doing it now. Thanks again :D Jun 28, 2014 at 3:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.