1

I'm using an Ubuntu 14.04 and a Wine 1.6.2. I successfully installed and ran GTA III from it and it works, except that there is no audio. I changed the setting from "speaker" to "headphone"(what I use) and even tried changing the in-game hardware options. It should be noted that I have never used Wine before this so it would most probably be a problem regarding Wine.

2

Wine is notorious for having problems with Pulseaudio, Ubuntu's default sound server. As a result, it is necessary for you to switch to ALSA. To do that, follow the below instructions.

  1. Run sudo apt-get autoremove pulseaudio from terminal
  2. Run sudo apt-get install gnome-alsamixer

Done! You can find more information here.

Additionally, Wine 1.6.2 seems to be outdated. Since you are trying to run games, you probably want the latest version. To install it, follow the below steps.

  1. Run sudo apt-add-repository ppa:ubuntu-wine/ppa
  2. When asked, hit Enter
  3. Run sudo apt-get remove wine wine1.6
  4. Run sudo apt-get install wine1.7

After that, you should be running the latest Wine.

| improve this answer | |
  • Thanks for the answer, but when I installed alsamixer, do I have to add it in Wine's settings or does it work without anything? In Wine's audio settings, I am unable to find it. I can only see "Default System" and pulseaudio. – UbuntuGuy007 May 27 '14 at 13:34
  • From my experience, it works out of the box, provided it is your system default. – Dillmo May 27 '14 at 20:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.