3

I recently installed Ubuntu 14.04 LTS on my Sony Vaio [nVidia GeForce 410M/PCIe/SSE2]. Earlier I had 12.04 installed on it, then I edited the xorg.conf file to control brightness using the function keys. But now the file is empty and even if i created it like last time it ain't working. I tried the xbacklight too, it didn't worked.

Please Help....

Thanks

EDIT: Ubuntu Installed is 64bit version.

  • Try second solution from askubuntu.com/a/266618/285763 (that one that starts with "Execute gksu gedit /etc/default/grub") – artis May 27 '14 at 13:44
  • @artis Sorry sir, That didn't work either. – Hitesh Bhatt May 28 '14 at 7:53
  • @HiteshBhatt did my answer work for you? – Korkel May 28 '14 at 8:11
  • @Korkel No Sir, It ended up even more screwed. The display went blank, didn't even showed in failsafe. – Hitesh Bhatt May 28 '14 at 9:03
5

I have a Sony VPCEH notebook, I had the same problem.

I tried this solution that worked for me: http://ubuntuforums.org/showthread.php?t=2221452#6

Briefly:

With root privileges, create the file /usr/share/X11/xorg.conf.d/20nvidia.conf with the following content

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 410M"
    Option         "RegistryDwords" "EnableBrightnessControl=1"
EndSection

Log out and back in again to test.

And it gently adds: "If something goes wrong, simply delete that file and reboot to recover the system."

But I didn't need that addition. After logout and login the brightness control started to work again.

I hope it helps you too...

  • worked for me... – pinkpanther Nov 17 '14 at 18:28
  • 1
    Works here with Macbook Pro, Ubuntu 15.04 and GForce 9400M. I changed the BoardName to "GeForce 9400M". – netAction Aug 12 '15 at 20:48
  • works with me VPCEH28FN with nVidia 410M – Abhishek Deb Feb 27 '16 at 18:08
2

edit note: don't change anything related to intel files especially usr/share/x11/20-intel because yours is NVIDIA and it broke my Ubuntu. I couldn't open Ubuntu anymore, so I removed 20-intel in safe mode from the console.

JUST do this to recreate:
this will recreate etc/X11/xorgconf be root then execute this on terminal

nvidia-xconfig

lastly be sure that you are pasting enablebrightness in right section which is section "device"

for nvidia and ubuntu 14.04 x64 check this post ... it solved mine.

ubuntu 14.04 fn brightness nvidia not working samsung r540

HOW I SOLVED IT

in terminal

# nvidia-xconfig

this creates /etc/X11/xorg.conf . edit it.

# sudo su  // become root
# gedit /etc/X11/xorg.conf 

find Section "device" in text. it should look like this on the right side:

from this                        TO   this     

Section "Device"                  | Section "Device"
 Identifier "Device0"             |   Identifier  "Device0"
 Driver     "nvidia"              |   Driver      "nvidia"
 VendorName "NVIDIA Corporation"  |   VendorName  "NVIDIA Corporation"
                                  |   Option "RegistryDwords" "EnableBrightnessControl=1"
EndSection                        | EndSection

save changes (ctrl+S).
log out. log in.

we are done!! now Fn + Up/Down is adjusting the brightness.

this post will make your fn+up ,down keys work

  • Awesome this is really well written and worked perfectly on Lenovo also – shaneonabike Aug 24 '15 at 0:38
  • Worked for my Sony Vaio like a charm. Thanks a lot @blackholeearth0_gmail! – Bakhtiyor Dec 5 '15 at 18:14
  • im looking this post at jan 2016 . and im really glad that at least Two people get benefit from this. thank you guys – bh_earth0 Jan 13 '16 at 15:49
0

Open a terminal and make this file if it doesn't exist:

sudo touch /usr/share/X11/xorg.conf.d/20-intel.conf

We need to edit that file, so enter the following in a terminal:

sudo gedit /usr/share/X11/xorg.conf.d/20-intel.conf

Then add the following in the file and save it:

Section "Device"
    Identifier  "card0"
    Driver      "intel"
    Option      "Backlight"  "intel_backlight"
    BusID       "PCI:0:2:0"

EndSection

Log out and in again, and it must work.

  • Be careful I tried this an it caused me not to be able to boot my computer anymore and had to run safe-mode and remount the drive and delete it completely – shaneonabike Aug 24 '15 at 0:37
0

Here is a Python code to alter the screen brightness BrightnessControl.

Before running check if the follwing file exists /sys/class/backlight/intel_backlight/brightness
The content of this file is an integer indicating the current brightness.

  • Thanks for your help, but the file does not exists. – Hitesh Bhatt Jun 14 '14 at 5:04
  • Locate the file which stores the current screen brightness and modify the code to make it work. – savsr Jun 14 '14 at 6:51
  • there is a link to another location as "acpi_video0" in /sys/class/backlight . It has files as "actual_brightness", "brightness" and "max_brightness", can you suggest me a script which allows me to change the brightness in "brightness" through the hotkeys? I need to change the brightness much often and can't stick to a single value. – Hitesh Bhatt Jul 3 '14 at 13:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.