6

I installed Geany IDE via Ubuntu Software Center. Wrote a hello world prog in C and it compiled successfully but when i tried to run it, it gave me this error:

./geany_run_script.sh: 5: ./geany_run_script.sh: ./hello: not found

------------------
(program exited with code: 127)
Press return to continue

Could someone please tell me what i should do?

3
  • What flavor/desktop of Ubuntu are you running? there is a known issues with the KDM default terminal (konsole) in geany – steeldriver May 27 '14 at 11:21
  • i am running ubuntu 14.04 lts – user280105 May 27 '14 at 11:45
  • me too...have the same problem.. I'm using ubuntu 14.04.1 (unity desktop) – Yuvaraj Jun 3 '15 at 2:44
8

You only compiled your source file, but didn't build your application, meaning the linking was not done and the executable was not created. Use the "build" sub-menu from the "build" menu (default shortcut is F9 if I recall correctly) and try again.

0
0

Update the Geany version from Ubuntu software center or Install a new version by removing the current one. I was also facing the same problem then i tried this method.

0

I tried all of the above and none worked for me. The easiest way is to add your program file path in Edit > Preferences > General tab > Startup tab > Project Files Save this.

Now, go to Build > Set Build Commands > Execute Commands > Execute add this as it is below: (don't miss the leading .)

."/%e"

Click OK. Now Build > Build (F9) and then Build > Execute (F5). Kaboom. Should work now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.