This is my 1st time to try a linux desktop on Ubuntu 14.04 with a hope to have a stable and usable version of linux. It worked well at the beginning with some popular applications at the first day.

However, for unknown reason, (maybe after installing Dropbox or after a system update), the software center was disappeared and all software installed via software center were gone together.

System Settings cannnot be launched. Then I tried this command:

sudo apt-get install --reinstall gnome-control-center

So system settings can be opened again but most items in system setting are not displaying. There are only 4 items there including Printer, Security and Privacy, Language, and Software & Update. All others are not there.

When I click About this computer, instead of displaying computer info, it displays System Settings now.

So what's going on with this? It's so frustrated.

BTW, I am an experienced Windows user and couldn't understand why the core components are disappeared in Ubuntu. Can you image that Control Panel is disappeared in Windows? In Windows, I can try system restore or safe mode. It seems I don't have options to try in Ubuntu.


  • Open system settings and click on all settings at the top left of the window, did that help? – Wild Man May 27 '14 at 6:02

You could try reinstall them by entering in tty2 with Ctrl+Alt+F2 and typing:

sudo apt-get update
sudo apt-get install --reinstall ubuntu-desktop

and that might work fine.

  • Hey Michael, this is a new user, am not sure he knows what tty2 is, leave alone how to enter into it. – Parto May 27 '14 at 6:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.