5

I have uninstalled HPLIP according to the directions on http://hplipopensource.com/node/188 from Xubuntu 14.04, meaning that I typed this into my terminal emulator:

sudo rm -rf /usr/share/hplip
sudo rm -rf /etc/hp
sudo rm -rf ~/.hplip
sudo rm -rf /var/lib/hp

Those commands removed everything, but a shortcut to HP Device Manager is still in my menu. Of course, when I click it it says it can't find the executable but that's normal because it's a shortcut. So, is this a bug or did I do something wrong and how do I fix it?

  • 1
    I am unsure you followed the directions completely, you were supposed to make an uninstall from the tarball. Then do those commands afterwards. You could try installing it again, or fixing/repairing, then go through the uninstall again. If possible you can try this guide too: itknowledgeexchange.techtarget.com/itanswers/hplip As it is all you did was remove the files – No Time May 27 '14 at 3:02
  • I see. I need to use sudo make uninstall, but I don't know where my source tarball is. I think I will try reinstalling HPLIP then looking for the directory and uninstalling it that way. I will let you know how that works out. – John Scott May 27 '14 at 20:43
  • I uninstalled hplip (by deleting the files shown above and uninstalling the hplip package using Synaptic) but my networked scanner (actually a multi-function printer/scanner HP Deskjet 2540) was no longer found by Simple Scan. I tried to put it back by installing hplip & hplip-gui but Simple Scan no longer found the the scanner. I noticed that the files above no longer existed. Any idea how to recover these files and thus (hopefully) make my scanner findable by Simple Scan again? – John Rose Aug 30 '18 at 5:52
15

Works for me:

cd /usr/share/hplip
sudo python uninstall.py
2

I fixed it! I just had to reinstall HPLIP, go to the directory where the installer extracted all of the files, run sudo make uninstall, delete the files using the commands, restart my system, and it was done.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.