5

I have got a weird problem. I installed eclipse for c/c++ Development using the following:

sudo apt-get install eclipse eclipse-cdt g++

after i opened eclipse, i tried to make a new project, but i didn't get an option to choose between types of projects (c project/ c++ project/ Java project) but just the option "project". this project did not generate a src folder. i didn't see an option to create a src folder as well. how do i fix that?

i tried installing it manually with the download from their site, but the program didn't even launch.

3

This answer is for the packages that you installed in Ubuntu 14.04 by running: sudo apt install eclipse eclipse-cdt g++

  1. Open Eclipse and select Help -> Welcome.

  2. The Welcome screen will appear. In the Welcome screen click Tutorials.

  3. The Tutorials screen will appear. In the Tutorials screen click C/C++ Development.

  4. A Help - Eclipse Platform window will open. Click Create a simple application.

  5. The Help - Eclipse Platform window will jump to the Tutorial: Creating a simple application section. In this tutorial, you will use the CDT to create a simple 'Hello World' application. The tutorial has screenshots to make it easy to follow.

After you have finished following the Creating a simple application tutorial, don't delete the 'Hello World' project that you made so you can use it as reference material for making your next C++ project.

0

That's how I was able to get eclipse-cdt to start:

First open you shell and type sudo -s and start eclipse as root. After this you should be able to run it as normal user.

But this has to be done for the first as root.

  • Simpler one-line solution that doesn't need a root shell: sudo eclipse – Kaz Wolfe Oct 8 '14 at 9:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.