0

This question already has an answer here:

I'm trying to install Ubuntu. My system have pre-installed Windows 8. I made USB bootable and then I booted into Ubuntu from there and I am in TRY Ubuntu mode now, I am having a problem in installing Ubuntu. When I attempt install Ubuntu then it says:

No root file system is defined. Correct this from the partitioning menu.

marked as duplicate by Eric Carvalho, Fabby, Jacob Vlijm, Luís de Sousa, David Foerster Mar 3 '15 at 21:54

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • What do you want to do with the Windows system? Replace it? – Lucio May 26 '14 at 21:09
  • No i want both windows and ubuntu to run side by side – user2831683 May 26 '14 at 21:10
  • Don't you have a "Install Ubuntu alongside Windows" option? – Lucio May 26 '14 at 21:11
  • I couldn't find any solution to my problem. can you please brief me a bit. I have set the password for root , now just that how can I define root file and what actually defining a root file means ? – user2831683 May 26 '14 at 21:22
  • 1
    sorry for duplication, but I was not able to find this. @Fabby, a good link on the problem – user2831683 Mar 3 '15 at 19:04
2

You need to specify which partition will be root (represented with an slash /) in the partitioning screen. If you don't know how to do this go back twice, and select the automatic installation (the one that doesn't say "Something else...).

To specify the root partition you have to be in the partitioning screen, select the partition where you will install Ubuntu, and then click "Change...". You will be presented with the following:

Thanks to Mateo

Here, in mount point you should select /, click ok, check again everything, and then continue.

Not the answer you're looking for? Browse other questions tagged or ask your own question.