0

I have Ubuntu 12.04 installed on my dell laptop for couple of months(didn't want it but my company forced it). Rescently I am having some issues in connecting to some wireless networks. So far I have been able to connect to any wireless network. But at present I am not able to connect to my new home wireless , however with same laptop I am able to connect to office wireless and my friends wireless.The wireless is detected by Ubuntu and is present in the list of connection but can't connect, if I click it it is instantly removed not even asking for password. i am able to connect to my home wireless through my iPhone which means that there is no issue with my home wireless connection setup. Even if I use the iPhone as hotspot still not able to connect via Ubuntu

Request some help.

closed as too broad by user.dz, BuZZ-dEE, Braiam, nux, Eric Carvalho May 28 '14 at 12:13

Please edit the question to limit it to a specific problem with enough detail to identify an adequate answer. Avoid asking multiple distinct questions at once. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • Please edit your question to add details of your wireless card from the terminal: lspci -nn | grep 0280 Thanks. – chili555 May 26 '14 at 17:51
  • Here is the output of the command lspci -nn | grep 0280 03:00.0 Network controller [0280]: Intel Corporation Centrino Advanced-N 6205 [Taylor Peak] [8086:0082] (rev 34) – Avishek May 27 '14 at 5:57
  • the output of nm-tool --- >> - Device: wlan0 --------------------------------------------------------- Type: 802.11 WiFi Driver: iwlwifi State: disconnected Default: no HW Address: 08:11:96:C0:1C:48 Capabilities: Wireless Properties WEP Encryption: yes WPA Encryption: yes WPA2 Encryption: yes Wireless Access Points (* = current AP) dlink123: Infra, E8:94:F6:3C:43:24, Freq 2437 MHz, Rate 54 Mb/s, Strength 54 WPA2 – Avishek May 27 '14 at 6:07
1

You do not have an Atheros wireless card, so the ath9k.conf file is ineffective. Since the problem is only with your new home wireless, I suspect it's a configuration problem in the router.

First, check the settings in the router. WPA2-AES is preferred; not any WPA and WPA2 mixed mode and certainly not TKIP. Second, if your router is capable of N speeds, I have better luck with a channel width of 20 MHz in the 2.4 GHz band instead of automatic 20/40 MHz. I also have better luck with a fixed channel, either 1, 6 or 11, rather than automatic channel selection.

Make sure the router is set to automatic B, G, N and, if it's capable, AC speeds, not locked to N and certainly not locked to AC since the Intel wireless device you have is not AC capable.

After making these changes, reboot the router.

0

I experienced this issue once. As far as i know, ubuntu can't connect to WPA 2 PSK wifi security. Try to change your wireless adapter security setting to WPA PSK. I tried this and it works now.

  • My wireless devices connect to WPA2 perfectly well. – chili555 May 26 '14 at 17:50
  • 1
    @AlKaef -- yes the wireless connection I am trying to connect is a WPA2 connection dlink123: Infra, E8:94:F6:3C:43:24, Freq 2437 MHz, Rate 54 Mb/s, Strength 54 WPA2 – Avishek May 27 '14 at 6:09
  • @Avishek have you tried to change it to WPA? – AlKaef May 27 '14 at 11:14
-1

Is the Wireless turned on? Can you run this script:

echo "options ath9k nohwcrypt=1" | sudo tee -a /etc/modprobe.d/ath9k.conf
sudo modprobe -rfv ath9k
sudo modprobe -v ath9k
  • 1
    How on earth would you believe he has an Atheros wireless card?? – chili555 May 26 '14 at 15:53
  • I also used this on a other wireless card. – Korkel May 26 '14 at 16:21
  • echo "options ath9k nohwcrypt=1" | sudo tee -a /etc/modprobe.d/ath9k.conf options ath9k nohwcrypt=1 sudo modprobe -rfv ath9k sudo modprobe -v ath9k insmod /lib/modules/3.2.0-51-generic/kernel/drivers/net/wireless/ath/ath.ko insmod /lib/modules/3.2.0-51-generic/kernel/drivers/net/wireless/ath/ath9k/ath9k_hw.ko insmod /lib/modules/3.2.0-51-generic/kernel/drivers/net/wireless/ath/ath9k/ath9k_common.ko insmod /lib/modules/3.2.0-51-generic/kernel/drivers/net/wireless/ath/ath9k/ath9k.ko nohwcrypt=1 nohwcrypt=1 – Avishek May 27 '14 at 6:26

Not the answer you're looking for? Browse other questions tagged or ask your own question.