I'm trying to use Banshee, but when I launch it, it shows this (fatal error) that seems releated to Mono (which is installed, but maybe not working..)

Si è verificata un eccezione non gestita:Sqlite error 11: database disk image is malformed (SQL: 
                BEGIN TRANSACTION;
                    DELETE FROM CoreSmartPlaylistEntries WHERE SmartPlaylistID IN (SELECT SmartPlaylistID FROM CoreSmartPlaylists WHERE IsTemporary = 1);
                    DELETE FROM CoreSmartPlaylists WHERE IsTemporary = 1;
                COMMIT TRANSACTION)

  at Hyena.Data.Sqlite.Connection.CheckError (Int32 errorCode, System.String sql) [0x00000] in <filename unknown>:0 
  at Hyena.Data.Sqlite.Connection.Execute (System.String sql) [0x00000] in <filename unknown>:0 
  at Hyena.Data.Sqlite.HyenaSqliteCommand.Execute (Hyena.Data.Sqlite.HyenaSqliteConnection hconnection, Hyena.Data.Sqlite.Connection connection) [0x00000] in <filename unknown>:0 
Exception has been thrown by the target of an invocation.

  at System.Reflection.MonoCMethod.Invoke (System.Object obj, BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) [0x00000] in <filename unknown>:0 
  at System.Reflection.MonoCMethod.Invoke (BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) [0x00000] in <filename unknown>:0 
  at System.Reflection.ConstructorInfo.Invoke (System.Object[] parameters) [0x00000] in <filename unknown>:0 
  at System.Activator.CreateInstance (System.Type type, Boolean nonPublic) [0x00000] in <filename unknown>:0 
  at System.Activator.CreateInstance (System.Type type) [0x00000] in <filename unknown>:0 
  at Banshee.Gui.GtkBaseClient.Startup () [0x00000] in <filename unknown>:0 
  at Hyena.Gui.CleanRoomStartup.Startup (Hyena.Gui.StartupInvocationHandler startup) [0x00000] in <filename unknown>:0 

.NET Version: 2.0.50727.1433
OS Version: Unix

Assembly Version Information:

gkeyfile-sharp (
Banshee.AudioCd (
Banshee.CoverArt (
Banshee.Mpris (
Migo (
Banshee.Podcasting (
Banshee.Dap (
Banshee.MultimediaKeys (
Banshee.Bpm (
Banshee.WebBrowser (
Banshee.Wikipedia (
pango-sharp (
Banshee.Fixup (
Banshee.Widgets (
gio-sharp (
gudev-sharp (
Banshee.Gio (
Banshee.GStreamer (
System.Configuration (
NDesk.DBus.GLib (
gconf-sharp (
Banshee.Gnome (
Banshee.NowPlaying (
Mono.Cairo (
System.Xml (
Banshee.Core (
Hyena.Data.Sqlite (
System.Core (
gdk-sharp (
Mono.Addins (
atk-sharp (
Hyena.Gui (
gtk-sharp (
Banshee.ThickClient (
Nereid (
NDesk.DBus.Proxies (
Mono.Posix (
Hyena (
NDesk.DBus (
glib-sharp (
System (
Banshee.Services (
Banshee (
mscorlib (

Platform Information: Linux 2.6.39-0-generic x86_64 x86_64 GNU/Linux

Disribution Information:



What can I try? I've tried to reinstalled both banshee and mono.

1 Answer 1


Sqlite error 11: database disk image is malformed

From this line of the log, it looks like your database is corrupt. You can probably fix it by following the instructions from the bottom of the Banshee FAQ page. Run the following in terminal:

cd ~/.config/banshee-1
sqlite3 banshee.db ".dump" > dump
mv banshee.db banshee.db.backup
cat dump | sqlite3 banshee.db

Usually this kind of database corruption happens as a result of a Banshee crash, or a system crash or power loss while Banshee is running.

Why is this so common with Banshee?

This type of error is more common in Banshee than other applications that use SQLite databases because of the way Banshee's database is set up. By setting PRAGMA synchronous to OFF, Banshee's SQLite database has increased performance, but unfortunately Banshee runs a higher risk of database corruption (but not data loss) as a result. Once Bug 621057 is fixed, users won't even notice this error anymore because Banshee will automatically recover from it.

  • Yep. Now it works! Thank you alot. I tought it was a mono error :|
    – Hadden
    Jun 6, 2011 at 12:33
  • 1
    @Hadden If that answered your question, please mark it as accepted by clicking the checkmark left to it. Thanks!
    – htorque
    Jun 6, 2011 at 21:28
  • I can confirm this also works for the latest 13.10 also. To bad this bug still hasn't been resolved Jun 16, 2014 at 17:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.