1

I edited fstab to mount a ntfs drive (of order /dev/sta5) on a location of order /media/usrname/TheDrive for a systemwide mount. I used the following line

UUID=TheDrive'sUuid    /media/username/TheDrive    ntfs-3g     rw,auto,auto,user,fmask=011, dmask=0000    0    0

The mount was successful. Now Im facing a problem: whenever I delete any data (dir as well as file) from the mounted ntfs partition using nautilus, the data gets directly deleted without being moved to TRASH. The "Move to Trash" of files in this partition is been replaced by "Delete".

I tried the same on "/home" and "/" files and "Move to Trash" is available and even works as normal and data is sent to TRASH when clicked.

2

Replace the options you have used to mount the partition with rw,auto,users,exec,nls=utf8,umask=003,uid=1000, replacing uid=1000 with the id of your user (you can get your id using id -u) so that the line in /etc/fstab looks like this:

UUID=TheDrive'sUuid    /media/username/TheDrive    ntfs-3g     rw,auto,users,exec,nls=utf8,umask=003,uid=1000     0    0

Files deleted from NTFS partitions are not moved to "Trash", they are moved to the /media/username/TheDrive/.Trash-1000 directory. You will have a files directory here which will store the thrashed files.

.Trash-1000 is a hidden directory. To see hidden directories in nautilus press Ctrl+h when you open nautilus.

  • Nope, In my case they dont. If I try to deleate a file, I get a dialog box "The files will be deleted permanantly..." and thus, they dont go to trash and are deleted directly instead. – about 99 ninjas May 26 '14 at 9:52
  • +if i locally mount a partition using nautilus the files go to trash as usual. Thus it a problem with system wide mounts only – about 99 ninjas May 26 '14 at 9:54
  • 2
    @about99ninjas: Can you try remounting replacing the options with rw,auto,users,exec,nls=utf8,umask=003,uid=1000, replacing the uid with yours? You can get your id using id -u. – jobin May 26 '14 at 9:57
  • thanks.. It worked btw can u please tell me what was wrong with wy fsab options? – about 99 ninjas May 26 '14 at 10:10
  • @about99ninjas: Not really sure, but that is how I have mounted my NTFS partition, will update if I find the cause. – jobin May 26 '14 at 10:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.